iSymphony and FreePBX Distro Question

Hello,

I wanted to use iSymphony with FreePBX Distro (1.87.29.55-2). As I saw the version installed is iSymphonyServer-fpbx.noarch 2.4.0_2681-1. The problem is that at http://www.getisymphony.com/download the client version is 2.2.0-2315 and they are not compatible. Is there any place to download the new client or should I downgrade iSymphony server?

Thanks in advance,

There is no clients anymore. You simply click on the operator panel button on your home page and that will let you launch the client direct.

Thank you very much and I should have looked for the obvious before asking :slight_smile:

I don’t see iSymphony installed and I have the same version (via upgrades since the first version). Is it because I installed FOP2? Or did I need to do something else? Is it safe to run ‘yum install iSymphonyServer-fpbx’? Can I remove FOP2?

Thanks much!

[[email protected] ~]# cat /etc/asterisk/freepbxdistro-version
1.87.29.55-2
[[email protected] ~]# rpm -qa | grep iSymp
[[email protected] ~]#

Yes you would need to remove FOP2 than install iSymphony.

Thanks Tony!

I did “yum remove fop2-freepbx-2-21”

Do I also remove the module “FreePBX FOP Framework” under module admin

Edit: Nevermind - there is no “remove” button for that code in module admin.

-Brian

Removed FOP2 with yum
Added iSymphony with Yum

Ended up with a few problems -

  • No “isymphony” directory at the top level of the web server (or an alias)
  • I added a link to a likely directory I found after the install, but it didn’t function after loading the java client.
  • My console is displaying a message about no permissions to update isymphony/variables.txt
  • freepbx_debug.log says the following every 30 seconds

2011-Dec-01 15:55:50 /var/www/html/admin/modules/dashboard/class.procinfo.php:21
[WARNING]: parse_ini_file(isymphony/op_server.cfg) [function.parse-ini-file]: failed to open stream: No such file or directory

2011-Dec-01 15:55:50 /var/www/html/admin/modules/dashboard/class.procinfo.php:12
[WARNING]: fsockopen() [function.fsockopen]: unable to connect to localhost:4445 (Connection refused)

Any suggestions? Or should I pass on this and wait until I reinstall again?

thanks!

The best way to get this the proper symlink is to first execute

“chown asterisk:asterisk /var/www/html/”

as root

Next go into the FreePBX module admin and uninstall the module, and then install to run the install.sh script again, which creates the symlink.

Make sure to remove the manual symlink you created before you do this.

Hi,

I get some error messages when I am trying to do a amportal start. What I get is

amportal start

Please wait…

SETTING FILE PERMISSIONS
chown: cannot access isymphony': No such file or directory chmod: cannot accessisymphony’: No such file or directory
chmod: cannot access isymphony/*.pl': No such file or directory chmod: cannot accessisymphony/safe_opserver’: No such file or directory
Permissions OK

STARTING ASTERISK
Asterisk Started

Is that a problem?

Thanks in advance,