Issues with Queue behaviour with Asterisk with FreePBX 2.10.0rc1 and Queues module


We’ve had an issue at a clients site recently where calls coming in to the phones on a Queue with ring behaviour ringall do not get sent to the phones correctly.

I would expect the oldest call in the queue to be sent to every handset until answered, which would then offer then next oldest call in the queue, etc.

Instead the first call gets sent to all the phones, then within half a second the next call, and the next, and the next, it will then loop back to the first call in the queue, only offering each one for a tiny amount of time but having no wait between each offering.

It had initially been reported that this issue was only affecting a remote site connecting to the main subnet via an OpenVPN, but since we’ve noticed this behaviour on the main subnet in the office as well. So it would just seem to be more apparent on higher latency connections, although I suppose there could be something else at fault here.

Any suggestions as to what to look for here to investigate the issue? We have tried looking at using another VPN (which obviously didn’t solve the issue as it wasn’t down to the VPN in the end) and started looking for any IP conflicts but haven’t found any yet. I have also tried changing the NAT type of an affected handset to all of the options within FreePBX and that didn’t seem to help.

We are using Polycom SoundPoint IP 321 phones on site.