Issues missing PJSIP

i am working on trying to get GVSIP going… but i am stuck having issues even getting PJSIP installed even as as part of a standard build. using the guild located here…

i am not seeing any errors displayed as i walk thru tall the steps.

howerver when ever i log in to asterisk and try a command like pjsip show endpoints it says no such command… however when i run the same command in my production freepbx the commands seem to work.

there is nothing about PjSIP in /etc/asterisk/modules.conf

i used CentOS-7-x86_64-Minimal-1804.iso that i just downloaded the other day.

i have probably attempted building this 20 times…

any help would be great… probably somethings simple i am over looking.

looks like it installed Asterisk 14.5.0 the last time i tried

after veifiy makemenu had everything selected i tried running module load chan_pjsip and i am now getting this

2018-07-07 13:24:00] WARNING[163829]: loader.c:526 load_dynamic_module: Error loading module ‘chan_pjsip’: /usr/lib64/asterisk/modules/ undefined symbol: ast_sip_cli_traverse_objects

Yep found that. So stopped looking that direction. Still can’t figure out why it’s not loading

try an iota of pjsip maybe

module load res_pjsip

found my problem. /ect/asterisk/ is empty … as soon as i had it make samples resolved my issue… but now to find out why i need to run make samples as this is bad.

not sure thas working either. running ldconfig -p | grep pj is not showing any of the pjsip stuff installed… so i continue on.

I started putting something together to get a FreePBX box up and running on Centos 7 using NAF’s gvsip branch of asterisk. Much of which was obtained and hacked together from others’ talent. Feel free to give that a try.

If virtualbox/vagrant are tools you are familiar with: (had to update link because forum wouldn’t allow me to post)

git clone https(colon)(slashes)github(dot)com(slash)jamiekowalczik(slash)asterisk-freepbx-gvsip(dot)git
cd asterisk-freepbx-gvsip/
vagrant up

When the box is all setup you will need to create /etc/asterisk/pjsip_custom.conf with your info.

If you already have a base centos 7 install and prefer not to use vagrant then the following ‘should’ work.
Preface: Alpha stage - do not do this on a functional box…

bash <(curl -s https(colon)(slashes)raw(dot)githubusercontent(dot)com(slash)jamiekowalczik(slash)asterisk-freepbx-gvsip(slash)master(slash)provision(slash)install(dot)bash)

The pre-requisite for that command is to have the 4 values needed for each google voice number (number, client_id, client_secret, refresh_token). The script will pause and ask you to set that up at which point you will open up another SSH connection to update the file with your text editor of choice - when complete press enter and the script will finish off the install. If you don’t have the values and just want to test out the install then press enter and use find/replace to put them in pjsip_custom.conf later on.

The file you will be asked to update is ./asterisk-freepbx/provision/freepbx-gvsip-el7.yml.

Near the top of the file you will see the following lines. Replace the 4 values surrounded by single quotes then save the file.

      - { number: '1112223333', oauth_clientid: 'asdf(dot)apps(dot)googleusercontent(dot)com', oauth_secret: 'XXXXXX', refresh_token: 'asdfasdf' }
      - { number: '1112223334', oauth_clientid: 'asdg(dot)apps(dot)googleusercontent(dot)com', oauth_secret: 'XXXXXY', refresh_token: 'asdfasdg' }

As noted - the code is ‘strange’. The project started out to be a way to deploy using vagrant and ansible but a previous co-worker had a centos7 install on a physical machine that he wanted to test naf’s gvsip on so that bash script mentioned in the provision folder will setup ansible on the centos7 host, pull down the ansible playbook, and install asterisk and freepbx using the playbook with one command. This is for a hobbiest install at best… Please feel free to clone to make more efficient and keep me posted on any developments. I will make my way to IRC some night - getting late for me.

I (edit: Had, it has now been broken by @anewb again) fixed the links in the previous post, but the actual code referenced is extremely strange.

Just do that. Don’t run the bash script.

Yes. Come talk to us on IRC, because you’re doing a bunch of wrong things in that script.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.