Issues forwarding messages in voicemail menu

This is a new one. They dial in (from their Yealink t48G), hit 1 to hear the new message, then hit 8 to forward, then 1 to enter the extension number, and then it hangs up. I tried it from here with another t48G using the same template and firmware and it works fine. Both phones connect externally to the PBX from different locations.

Looking at the log I see a message about an incorrect format for one of the greetings but fixing that and trying several different extension numbers yields the same result. Not sure where to look. Below is the log.

[2020-03-13 12:04:32] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-password.ulaw’ (language ‘en’)
[2020-03-13 12:04:35] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-youhave.ulaw’ (language ‘en’)
[2020-03-13 12:04:36] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘digits/20.ulaw’ (language ‘en’)
[2020-03-13 12:04:36] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-first.ulaw’ (language ‘en’)
[2020-03-13 12:04:37] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-message.ulaw’ (language ‘en’)
[2020-03-13 12:04:38] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘/var/spool/asterisk/voicemail/default/282/INBOX/msg0000.slin’ (language ‘en’)
[2020-03-13 12:04:41] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-forward.ulaw’ (language ‘en’)
[2020-03-13 12:04:42] VERBOSE[5564][C-000014c2] file.c: <SIP/282-00001677> Playing ‘vm-extension.ulaw’ (language ‘en’)
[2020-03-13 12:04:47] WARNING[5564][C-000014c2] format_wav.c: Not a supported wav file format (49). Only PCM encoded, 16 bit, mono, 8kHz/16kHz files are supported with a lowercase ‘.wav’ extension.
[2020-03-13 12:04:47] WARNING[5564][C-000014c2] file.c: Unable to open format wav
[2020-03-13 12:04:47] WARNING[5564][C-000014c2] file.c: Unable to open /var/spool/asterisk/voicemail/default/283/greet (format (ulaw)): No such file or directory
[2020-03-13 12:04:47] VERBOSE[5564][C-000014c2] pbx.c: Spawn extension (from-internal, *97, 118) exited non-zero on ‘SIP/282-00001677’
[2020-03-13 12:04:47] VERBOSE[5564][C-000014c2] pbx.c: Executing [[email protected]:1] Macro(“SIP/282-00001677”, “hangupcall”) in new stack

Update: this seems to be something with the creation of the extensions. Creating a new extension and forwarding messages from there seems to work just fine. Also, UCP seems to work fine for forwarding on both old and new extensions. I successfully sent a test message back and forth between the two mailboxes.

I also got an error screen when accessing the endpoint manager which instructed me to do a fwconsole chown which fixed the GUI issue. Waiting for them to clear out so I can dial into one of their voicemail boxes to see if the issue is still happening.

Was the issue resolved after using fwconsole chown?

No. Will try deleting the extension and recreating it. This was one where we ran the conversion so it’s possible that something got damaged in the conversion. Will report once I’ve had a chance to try that.

Based on this, that makes it seem like it is not working for the converted extensions but it is working for extensions created after the conversion.

If that’s true, you may end up having to rebuild all of the extensions.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.