Issues Adding Extension

I’m currently setting up my FreePBX box up at our datacenter. The issue I’m having is when I go to Extensions and select Generic SIP Device then click Submit it just hangs there. Nothing happens and after about 10 minutes it takes me to a blank page. What can be causing this? I thought it might’ve been a firewall issue so I then tried it on a server in my datacenter and that too did not work.

that is quite strange, especially if other screens work properly. Do make sure you have not un-official modules installed, which would be anything that is not available through the online repository. Also - make sure your php.ini memory limit is high enough (just crank it to something like 80MB to be safe). The problem you describe typically does not happen on just a single tab of FreePBX while others are working?

Strange, this same thing happend to me last night. I installed a PBX using trixbox 2.4 ISO with CentOS 5.1 and FreePBX 2.3. I played with the trixbox Endpoint Manager a bit trying to get that to work, after which I got what you got. Frustrated after several hours searching the 'net, and unable to find a solution, I reinstalled the ISO. Now I can add extensions with FreePBX. I’ll have to handcode files I guess.

None of the tabs work. They load up but then just hang when you try to submit anything.

I just had the same thing happen to me today. In my case all of the other tabs work but adding an extension (doesn’t matter what type) just hangs there. I was able t oget it to attempt to add an extension first thing this morning but that ultimately failed (either because of the impending error or whatever this is, or because I didn’t know what I was supposed to fill in). In any case it never created that first extension amd since then has refused to create any more. I did see mention of a yum update a day or two ago that was causing systems to crash but that was pulled and fixed so I doubt the two are related as I didn’t do any updates until this started happening. I’m going to reinstall as I have to have this server up and running before the end of the week but I wanted to let you know it’s not just you and at least in my case is just one tab that isn’t working correctly.


Yup I just rebuilt my machine and it’s working now. Very weird.

Have you done any updates either to asterisk/trixbox or freepbx since reinstalling? I’m not sure if I want to update and have it happen all over again. I’m reinstalling now and can play with it remotely tonight but I was just wondering if you’ve already tried anything and had it work/not work.

Not yet I will do some later on tonight.

Well it doesn’t seem to be an update that did it. I ran updates to both trixbox and freepbx in batches and after every batch I tried adding a SIP extension and every time it worked without a problem. So far though I haven’t actually added anything or done any other configuration to the server. I’ll try that tomorrow or tonight and let you know if I have any other problems.

There are other logs you can check when this sort of thing happens. In this case, since this is on the web interface you can check /var/log/httpd/* and maybe there will be a clue buried somewhere.

I have the same issue. I’ve reinstalled from the ISO several times. Everything seems to work until i try to add extensions. The following fills my error_log in httpd:

-bash: syntax error near unexpected token (' [trixbox1.localdomain httpd]# [Sun Jan 27 13:26:46 2008] [error] [client] PHP Warning: fgets(): supplied argument is not a valid stream resource in /var/www/html/admin/ on line 971, referer: -bash: syntax error near unexpected token(’
[trixbox1.localdomain httpd]# [Sun Jan 27 13:26:46 2008] [error] [client] PHP Warning: fclose(): supplied argument is not a valid stream resource in /var/www/html/admin/ on line 1019, referer:
-bash: syntax error near unexpected token `(’
[trixbox1.localdomain httpd]# [Sun Jan 27 13:26:46 2008] [error] [client] PHP Warning: fopen(/etc/asterisk/ [function.fopen]: failed to open stream: Too many open files in /var/www/html/admin/ on line 970, referer:

I have the same issue with the vmware image.

I’m running trixbox If i have a fresh install i don’t have any problems. it’s only after i install a series of packages and upgrades that it starts occurring. i’m narrowing down which one now.

I have the same issue. If I install the image it doesn’t occure. But after I update all available Trixbox packages i can’t set up extentions.

Well after I rebuilt the server and tried adding the extension it worked fine. I think it might’ve been one of the packages I installed. I didn’t have time to figure out which one since I was on a deadline but that was the only difference between the time I had the extensions not work for me and now.

In all three files:, and voicemail.conf all have the same content:

At line 1008 of /var/www/html/admin/ the recursion then runs the user out of fd resources when it recursively calls itself.

What are the contents of each of these files supposed to be on an unconfigured system?

There should not be a context defined in or The snipet you showed above is correct for the top of voicemail.conf. I’ve tweaked mine to have a zonemessages context with timezones defined in it but that is for my setup.

Well, I’ve nuked their contents for the moment. Adding extensions works again, but I may well have broken something else.

I’ll see at what point patching and updates corrupts the vm_* files if I can on another system.

I’ve manually cleaned up the files and it works. It’s just odd that it happens.

I was having this problem. It was cleared up by uninstalling the ConfigEdit module that PIAF included with the distro.