Issue with upgrade Outbound Route Viatalk vs Magicjack

Hi, I hope someone can point me in the right direction.

I have 2 SIP accounts, one is through ViaTalk and the other is MagicJack which I have extracted the user name and password from the dongle unit and configured in Asterisk via the normal trunk configurations.

In order for Viatalk to work properly, there are some SIP settings that are needed to be added. If they are not there, then you do not hear from the originating call. Specifically, the following I have tracked down as the one that is needed to hear the call from the originating end:


When you set this in ASTERISK SIP SETTINGS under other SIP Settings, VIATALK works properly, but then the MagicJack outbound route does not and you get the “The number you have dial is not in service…” and that appears to originate from Asterisk and not MagicJack’s Asterisk server (It is announced almost at once).

All was fine and co-habiting prior to the 2.7 upgrade.


FreePBX 2.7.0RC1
Asterisk Ver.

Anybody have any ideas what changed from the 2.6.X to 2.7.x ???

I am fairly new to Asterisk and also Linux so if you have something you want me to try or run diagnostics, I would greatly appreciate a step by step.

Also, the setup for Magicjack requires either I modify the sip.confg file (which I have not done) or use a work-around which is to port forward and use MJMD5 program on a PC, which has for the last 2 months worked great and only after I upgraded to 2.7 did this issue occur.

Thanks for your help.

I searched for a solution to this, but could not figure out what to do. Then it dawned on me that perhaps you could place the sendrpid=yes in the trunk setting, which I tried and it does work that way.

If anyone needs help on setting up Viatalk or MagicJack, please contact me. I have some txt files that might just help you and instructions.

MagicJack will not work with a standard SIP client. They added a proprietary authentication layer to avoid this kind of use.

There is however some ways to use MagicJack with a SIP phone/ATA/PBX.
For the Asterisk solution, you will have to patch the file.
Read this interesting thread that explains how to do it: