Issue with Softphones

Hi, I have successfully installed Free PBX on a server. I have also configured the extensions and connected the Softphones successfully. Softphones were registered successfully and when I dial an extension it rings. But I can’t hear anything both ways.

The server has no internet and I’m testing softphones within the Local network.
*43 echo ring works on both extensions.

Support from the community is highly appreciated.

From the distribution, onto a bare machine, or just FreePBX? In the latter case, you probably have a firewall blocking the RTP port range. (That’s probably true in both cases, but using the distribution should avoid its happening on the actual FreePBX machine.

Thank you for the reply.

It’s the distribution. Do you mean the FreePbx firewall blocking the RTP port range?

The Linux firewall. The FreePBX firewall is a front end to manage the Asterisk firewall, although other components also manipulate it.

The other common cause of lack of audio is NAT, but I assume this is all on one local network.

1 Like

yes in the local network. Thank you for the reply. I’ll try this.

If this is successful, I’m going to try this on the cloud. Will NAT issue will arise if using a cloud server as a host for FreePBX?

Thanks.

Depends on your network topology and whether or not you hide NAT by having the cloud machine withing your VPN. Most phones can handle NAT if the system is configured correctly. The main reported exceptions are some re-flashed CIscos.

1 Like

If running in a VM, confirm that you are using bridged networking.

In Asterisk SIP Settings, confirm that Local Networks and External Address are correctly set. If you really have no access to the internet, use a dummy value such as 1.1.1.1 for External address. If you change these settings, after Submit and Apply Config you must restart Asterisk.

Confirm that you don’t have many codecs enabled. Checking only ulaw and alaw would be a good start.

Confirm that Direct Media for the extensions is set to No.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
paste the Asterisk log for a failing call at pastebin.freepbx.org and post the link here.

1 Like

Thank you all for the support. Now it works on VM. Will try to move to a private cloud to do the testing. thanks again.
@david55