Issue with replication of FreePBX VM's


I am having an issue with the most recent stable version of FreePBX. I am running framework on a CentOS 6.8 32bit VM. The issue arises when replicating VM’s. I have always used Veeam replication between hosts (VMware ESXi standalone servers) in the past using older FreePBX frameworks (FreePBX 12.x with Asterisk 1.8) with no problems. But with the most recent stable version, the replication process seems to break Asterisk, preventing it from starting correctly. I am having the exact same issue when running FreePBX on a 64bit CentOS 6.8 VM. I have tried using different Veeam Replication versions, and replicating to different hosts. The issue stays, regardless.

When I run “service asterisk status” on the replicated VM’s, I always get the “asterisk dead but subsys locked” message. I tried everything to get Asterisk to start, but nothing seems to work. Any insight on how to resolve this issue would be greatly appreciated.

No one ever had an issue with replicated FreePBX VM’s and the asterisk service not starting up?

UP !



Try running Asterisk in a terminal with “Asterisk -cvvvv” to see the errors or warnings. Then it might be more clear what the problem is.


Since Asterisk does not start, I cannot open CLI

You can’t log into the console as root? That was the suggestion.

If you can’t log in as root, you have a much bigger problem than asterisk not starting.

The issue is not with logging into the console…I always work with the terminal.

As stated in my original post, if i try starting the Asterisk service after a replication, it fails with the mention ‘asterisk dead but subsys locked’