FreePBX | Register | Issues | Wiki | Portal | Support

Issue with Polycom IP330 freezing

configuration
freepbx
Tags: #<Tag:0x00007f749c2e7850> #<Tag:0x00007f749c2e75d0>

(Phil Grace) #1

Hello all. I’m new and have setup freePBX for the first time. Before I moved all our phones over from an old trixbox system, I used a test phone of each model on the new system to make sure everything was right. Everything looked good so I moved all the phones over… Bad idea.

The test Polycom IP330 worked flawlessly, but every other IP330/320 we have doesn’t work for more than an hour or two and freezes. I’ve been looking at this for days and can’t find a difference between the phones or extensions and can’t explain why one phone works great but the rest don’t.

I’m using the Commercial Endpoint manager and I’m on the newest version of Free PBX with asterisk 13.22.0. The IP330 phones are on firmware 3.3.5

Now I did find this old thread, but the last message was something about “you need to click on install firmware” not sure what that’s about.

Any help or ideas is appreciated.


#2

Did you factory default the phones?


(Lorne Gaetz) #3

Are you using pjsip? Strange SIP NOTIFY behavior


#4

Let me guess… you created your first extension a while ago and did your testing. After a few weeks or months, you felt good with migrating - you upgraded your modules on freepbx because you saw there were updates and then created all your new extensions.

Your old extensions still worked great, but all phones registered to your newly created extensions started to lock up after a few hours?

This is due to a change of a setting regarding MWI in a recent module update. Check out my post that Lorne posted above for the solution


(Phil Grace) #5

yes, I factory reset them all especially since they were updating firmware…


(Phil Grace) #6

Yes, I’m using pjsip for all extensions.


(Phil Grace) #7

That’s it exactly! thank you, I’ll look around for what you are talking about.


(Phil Grace) #8

Ok, so I read thru that thread and I found the MWI setting to force solicited. I also noticed the Aggregate MWI setting below it. Did you turn on aggregation as well?


#9

I haven’t confirmed if the aggregate setting is needed or not, but the issue is fixed just by forcing solicited.

Keep in mind that that the default to aggregate was yes before the change and now it is no. I personally have been setting aggregate to yes as well to keep the settings consistent to what they have always been


(Phil Grace) #10

Thanks. Further info. Looks like the lines that worked fine had aggregate enabled and auto on solicited. Looks like aggregate was enough to make the difference. I’ll make sure aggregate is on for everyone, then I’ll set some as force solicited and leave others on Auto and see which works out better.