Issue with HTTPS Setup - Certificate-Installation not possible because of Error

Hi everyone,

I am trying to secure the Web-Gui and force HTTPS.

As far as I know I have to:

Install an Certificate in Certificate Manager (done) and then go to Admin -> System Admin -> HTTPS Setup

There I should select the certificate I want to use and click on install.
The Problem is: If I select the newly generated certificate from Lets Encrypt, Installation is not possible because of an Error, see screenshot at

I have no clue, why this is not possible. The certificate was created a few minutes ago, so it should be fine.
There is no addition error message and if I try to use the auto-generated self-signed certificate I receive the same error.

Can somebody give me a hint what is wrong?
Thank you!

Did you generate the cert for a valid FQDN that resolves to your PBX?


yes, I do. The Lets Encrypt certificate seems fine. Without FQDN it would not be possible to create an Lets Encrypt certificate. I can also create a new certificate without any problem.
This issue also happens with the auto-generated certificate, so I doubt that the certificate itself is the problem, in my opinion it must be something different.

I received this error briefly. I noticed the gear in the upper right side was red. It went away after page refresh. One thing to try is to disable the page HTTPS redirect, try setting the certificate and then re-do the HTTPS redirect.

For HTTPS redirect I did this.
nano /etc/httpd/conf.d/redirect-443.conf

<VirtualHost _default_:80>
ServerName mydomainname:443
ServerSignature Off

RewriteEngine On
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

ErrorLog /var/log/httpd/redirect.error.log
LogLevel warn

The gear is not red but rotates all the time.

I have tried your solution.
But outcome was the same.

But I could solve the issue, how:

I deleted all certificates, self-signed and lets encrypt.
Then generated a new Lets Encrypt Certificate (but NOT a self signed certificate)
Changed to HTTPS Setup and was able to install the certificate.

Important is, that ALL certificates must be deleted, I tried it first with only deleting the self-signed or the lets encrypt and it did not work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.