Issue with GUI and Trusted Interfaces

Hello - I am new here - so be gentle. Need some help understanding this and figuring out what my options are.
By default a new interface gets configured as ‘Trusted’ and needs to be changed to Internet/external/whatever you need. I am good with this.
Now - take a system with only one interface (eth0) - make a change in System Admin/Network to that interface (you don’t even have to make any changes) - and save it. Now once again eth0 is a new interface and once again ‘Trusted’.
Was this by design? It seems like a bit of a security burp to me. I understand that you won’t have to make a bunch of changes to an interface/ip parameters after initial setup but still… Seems to happen on both ver 13 and 14 - multiple units.
Questions I have …

  1. Is it doing this on anyone else’ unit (surely someone has a test unit out there)?
    Further questions to come after verification of question 1

This runs counter to my experience. Keep in mind, I’ve only been working with FreePBX for about 15 years. so there are still things for me to learn, but this isn’t how any of the systems I’ve ever configured has worked.

I have heard similar problem statements from people running on various VPS and Hosted systems, but that’s not a problem with FreePBX, it’s a problem on the way the VPS reports its interfaces to the system. In those cases, there are “extra-PBX” settings that you need to make in the Ethernet configuration files to tie the interface to the system in a repeatable, non-duplicating way.

First off - I feel dumb for failing to mention that they are virtual (ESXi 6.0). It still seems strange to me that this would be the case. Nevertheless - I would love to know what those extra-PBX settings are as well as recommended adapter for the vm.

Thank you for your previous response.

We’ve heard reports specifically about ESXi systems doing stuff like this. If you scan back through the archive, you should find a couple of threads from about 3-4 months ago where a variation of this came up. IIRC, there are some settings in the eth0-ifup (???) file that have to be hand-coded. I don’t remember which ones, but a quick search through the search option at the top of the page should yield some information. I’d start with “ESXI ETH0” for the search.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.