Issue with connecting to asterisk

I just ran module updates and now i can’t connect to asterisk. I keep getting this error:
[FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting
I tried changing the password in /etc/manager.conf and in Advanced settings in the web gui, and i’m sure they match, but i still get the error. I tried updating the sql password with this query that i found in another forum:
UPDATE freepbx_settings SET value=‘mypassword’ WHERE keyword='AMPMGRPASS’
But i still get the error and asterisk won’t reload. I also can’t load the asterisk page in the web gui.
I am running version FreePbx

In the manager*conf set, check the ACL lists to make sure your server is allowing access to Asterisk from the manager.

/var/log/asterisk/full should tell you what the hang-up is.

you can also see this error if the asterisk service is not running as user asterisk.

thanks for the input. I got it resolved last night at 3 am lol. I opened an irc session and someone gave me this info.

I checked the asterisk modules

There were segmentation errors.
the following 2 files were missing and had to be created
touch /etc/asterisk/cel_custom_post.conf
touch /etc/asterisk/cel_general_custom.conf
then i reloaded and it was working.

I agree. There are several things that can cause this - the asterisk user problem is a common one. Modules failing, config file errors, updated passwords, and several other “one off” things can cause this as well.

It makes sense - this is a big machine with lots of little parts. It only takes one strange thing no one thought could be a problem to make is stop working.

My problem was that, before the upgrade, I was having trouble with the loopback interface, so I set everything up to connect to the 192.168.x.243 address (instead of using localhost). This worked fine until I upgraded to the latest FreePBX, which changed the “don’t use the loopback interface” changes I’d made back to the default.

If asterisk is up and running and the Manager can’t connect to it, the log /var/log/asterisk/full should point you to the actual problem you are having. If the Asterisk server isn’t restarting, the problem is more often some variation on the problem Bill had, where one or more modules is failing because of a thrown error isn’t caught.

My system has been running for so long that I’m all but certain that there is cruft in here that needs to be cleaned out. The …/full error log has a couple hundred error and warning lines that don’t hurt anything, but should be fixed at some point. When I’m completely out of work for other people, I’ll try to get on that. :smile: