FreePBX | Register | Issues | Wiki | Portal | Support

⚠ Issue on all FreePBX updated - not working with Bria Push Service

bug
freepbx
Tags: #<Tag:0x00007fafc33b9460> #<Tag:0x00007fafc33b9190>

(Sébastien Sciboz) #1

I know we could blame Bria first, but I’m trying and testing since Months.
I reinstalled a Fresh FreePBX instance and made the tests. So it’s not only my old instance.
Worst, it’s doing the exact same thing at my work.

The thing is, if I have a queue ringing agents, it’s fine for any SIP devices, real devices, apps and so.
It works fine with Bria for Teams, Bria Mobile… except when we use the Push Service.

So let’s say I got a call and this one go to a queue, and makes these phone ringing:
101 - Desktop phone
102 - DECT phone
201 - iPhone via Bria (mobile)
202 - iPad via Bria (mobile)

If they ring all, and I answer from 101 or 102, everything works fine.
If they ring all, and my iOS devices have the app in front and open, they ring and I can answer, it’s fine

But, if the iOS app is closed or in background, then I go a push notification from Bria, and I can answer. But then, the caller still listen to the ring and the PBX is “crashed”: it loops and you can’t do anything anymore, you only have to restart it.

I’ve made tests with different internet providers: all the same
I’ve made tests with different instances and new installed FreePBX: all the same
I’ve been in contact since a while with Bria: we’ve made a lot of tests, but not able to see what’s happening there.

Problem: it was working fine some months ago (sorry I don’t had enough time to make all tests straight forward). And suddenly all instances have this problem. Bria was not updated while the problem first appeared. I was blaming my internet provider, but no.
And at work, I was not using Bria Push at the beginning but now I do, it’s doing the same error.

So I assume something is not working between these too - but I’m sure a FreePBX update made this problem.

I need help to solve this: it’s a total nightmare now.

Thanks


#2

FreePBX version? Asterisk version? If you temporarily route a DID directly to ext. 201 (no queues, ring groups or follow me), does that still fail? Is extension 201 pjsip or chan_sip? If you try the other, does it fail in the same way?

What gets logged on a failing call? (If direct to 201 also fails, post that because it’s easier to analyze.)

When the system ‘crashes’, do you still have access to the GUI? Via SSH? If you still have SSH access, does
fwconsole restart
bring it back to life?

Have you tried another app with push such as Groundwire?

Have you used
pjsip set logger on
or
sip set debug on
to view the SIP traffic? If so, post the incoming packet that causes the crash, and what Asterisk logs as a result.

I have a reasonably recent test system (FreePBX 14.0.13.2, Asterisk 16.3.0, Groundwire 5.2.15 on Android 8.1.0) that works fine with push. My older systems also work ok with Groundwire. Sorry, no experience with Bria.


(Sébastien Sciboz) #3

FreePBX 14.0.11 13.26.0
It fails with Bria Push only, or some random times when an extension routes to an external number.
It’s totally not possible to understand. Sometimes works, sometimes make all crashing.
Especially when I have a queue timeout going to a ring group it works, but when I call forward to this same ring group, I have no sound when I call it - WHY.

But other scenarios works always good, calling directly the extensions, the ring group works always fine.

So when it bugs, I can’t call or reach anything, web browser seems to be working normally (but if I make changes and apply it is stuck there). fwconsole restart doesn’t work. I’m forced to “reboot” and usually it takes ages (waiting calls to terminate because it think calls are actually in use). The dashboard show an interesting thing: when it bugs, it says that a lot of channels are “in use”: generally it’s more than the reality, sometime the double.

Another Push App (Peoplefone) works but it’s not the same usage. And I paid for Bria so I want to solve this.

Here is the log just calling a queue with all extension with DND. It rings, but if I hangup and call again, free pbx is crashed. Let’s start there.

log1.tgz (8,2 Ko)


#4

Your trouble is likely:

If downgrading (or upgrading) doesn’t help:

It’s hard to read the log because you have all the DEBUG stuff but none of the higher level (VERBOSE, NOTICE, etc.) for context. Also, the SIP traffic would be useful.

Do you have the UDP port range for RTP (default 10000-20000) forwarded to the PBX? What kind of router/firewall do you have?

Have you tried using pjsip for the extension?

You seem to be using g722 on the extension side. If there is no benefit (because the trunk is alaw), try allowing only alaw and see whether it makes a difference.

The extension seems to be on a cable modem / Wi-Fi – is that correct? If so, does it fail the same way when using mobile data?


(Sébastien Sciboz) #5

My Gosh, I’ll never update anymore…
How to destroy your startup by just staying up-to-date :frowning:


(Itzik) #6

Correction: by not reading online before updating.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.