Issue Installing FreePBX - No connection to asterisk (Solved)


(Dnld) #1

Hello. I am new to asterisk and freePBX. I set up a server years ago but it was very basic and used for less than a month. I’m now launching a new company and found myself in need of a VOIP system so I’m back to asterisk. I installed asterisk on my debian VPS, then installed free PBX. At first i was having issues with getting the freePBX installer to find my asterisk server. After creating an aserisk user on debian and changing the run user-group in /etc/default/asterisk the installer worked.

After the FreePBX installation, localhost/ was redirecting to localhost/admin/config.php but was only showing a blank screen. After running fwconsole ma installall the page started working. Despite that, connection to asterisk cannot be established. I also found that when accessing advanced settings in the FreePBX interface I get a border but no settings, just a blank box.

Running fwconsole start works just fine, but when running fwconsole restart I get get UCP Node Server is not running. When running fwconsole restart again I get Core FastAGI Server is not running & UCP Node Server is not running.

After checking logs for freepbx I found this:
[2020-Nov-23 14:42:32] [freepbx.INFO]: Connection attmempt to AMI failed [] []

The UCP error log in asterisk yielded this:

2020-11-23 13:40 +00:00: { [Error: Can’t connect to MySQL server on ‘::1’ (111 “Connection refused”)] code: 2003 }
2020-11-23 13:40 +00:00: There was an error with MySQL Connection

ucp_out.log in asterisk displays this:

2020-11-23 13:40 +00:00: Starting FreePBX…
2020-11-23 13:40 +00:00: { AMPDBUSER: ‘freepbxuser’,
2020-11-23 13:40 +00:00: AMPDBPASS: ‘****’,
2020-11-23 13:40 +00:00: AMPDBHOST: ‘localhost’,
2020-11-23 13:40 +00:00: AMPDBNAME: ‘asterisk’,
2020-11-23 13:40 +00:00: AMPDBENGINE: ‘mysql’,
2020-11-23 13:40 +00:00: datasource: ‘’ }

I am using mariadb, is there a way maybe this user or database does not exist?

-------- UPDATE --------

Used a slightly older version of asterisk and it worked. I think this is some weird bug or something. Thank you.


#2

What version of node do you have? Most find 8 or 10 working on debian, older or newer, not so much. (Make sure you also have mongodb working)


(Dnld) #3

Version 10.3. Will try downgrading to both 10 and 8. Will update if this works. Thank you!


(Dnld) #4

No Luck. Tried both version 8 and 10, same issue. I think it has something to do with mariadb logins. Thanks for the reply.


#5

Make sure the password in the gui advanced settings matches one in /etc/asterisk/manager*.conf


(Dnld) #6

As mentioned above for some weird reason my advanced settings tab is not working. I just get a blank box. I can see the reset and save buttons bellow the box but nothing more than that. Very weird situation.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.