Issue installing certificate

Hi,

FreePBX 13.0.190.19, Certificate Manager 13.0.36.4, System Admin 13.0.73.9

I’m having an issue installing a GoDaddy certificate which I need to provide secure remote access to UCP

The CSR generation and certificate upload where done using Certificate Management and that all seemed to work OK. The issue I’m having is trying to install the certificate using Sytem Admin\HTTPS Setup. As soon as I click on the settings tab I get the following error

“Whoops\Exception\ErrorException Undefined offset: 1 File:/var/www/html/admin/modules/sysadmin/SSL.class.php:167”

I can select the GoDaddy certificate from the drop down box and click Install and then the button changes to installing but nothing else happens.

Can anyone give me a pointer on how to troubleshoot further ?

Any help would be greatly appreciated.

John.

No one has any ideas regarding this one, I am also getting this??

Current Version 10.13.66-20
All modules up to date
Asterisk 11

Here is another person getting the same error, with no responses to his request as well …

I installled the ssl cert manually because I could never get the cert manager to work with my wild card ssl cert

Hi,
I suspect it is a bug in the HTTPS Setup code of the System Admin module.

I got it working by manually installing the certificate after uploading it using the Certificate Manager feature in FreePBX. This is the process I went through.

  1. Uploaded the certificate using Certificate Manager
    This puts the certificate, authentication chain and private key into the /etc/asterisk/keys folder
  2. Manually copied the uploaded .crt file to /etc/httpd/pki/webserver.crt, the .key file to /etc/httpd/pki/webserver.key and the .pem file to /etc/httpd/pki/ca-bundle.crt
  3. Edited the /etc/httpd/conf.d/ssl.conf file and changed the ServerName to my FreePBX FQDN.
  4. Restarted the webserver.

I stll get the ErrorException error when I click on the Settings tab in System Admin/HTTPS Setup but SSL connections to the FQDN of my FreePBX Web Administration site and UCP site work fine.

Thanks for the reply. I hope it gets fixed soon. :slight_smile:

Well it won’t get fixed because there’s no bug report on it.

Anyways

/usr/bin/openssl x509 -in <cert> -noout -subject -issuer

/usr/bin/openssl req -in <csr> -noout -subject

Please run those two lines above so that we can figure out the problem. Post the results here or PM me.

/usr/bin/openssl x509 -in -noout -subject -issuer

[[email protected] ~]# /usr/bin/openssl x509 -in /etc/httpd/pki/webserver.crt -noout -subject -issuer
subject= /OU=Domain Control Validated/CN=pbx111.website.com
issuer= /C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certs.godaddy.com/repository//CN=Go Daddy Secure Certificate Authority - G2

/usr/bin/openssl req -in -noout -subject

[[email protected] ~]# /usr/bin/openssl req -in /etc/asterisk/keys/pbx111.csr -noout -subject
subject=/CN=pbx111.website.com/O=CompanyName, Inc./OU=Main Office/C=US/ST=Illinois/L=Chicago/[email protected]

Hope this is what you were looking for @tm1000 Andrew, I have sanitized it of course.

@tm1000 Hey Andrew, just an update here not sure if this helps in any way …

I got the following devices all making secure calls now except for the Sangoma S500 phone.

  1. Grandstream GXP2160
  2. MicroSIP softphone
  3. Bria softphone

The Bria also shows me shield telling me that it is a secure connection like the Grandstream GXP2160 has a lock. The MicroSIP doesn’t have a visual indication from what I can see.

@tm1000 Andrew the bug has been logged

https://issues.freepbx.org/browse/FREEPBX-14879

1 Like

I have the same issue. FreePBX 13 with all updates. I purchased a GoDaddy SSL and installed it successfully with Cert Manager. I have the paid Sys Admin module. When I click Settings from the HTTPS setup I get the exact same error “Whoops\Exception\ErrorException Undefined offset: 1 File:/var/www/html/admin/modules/sysadmin/SSL.class.php:167”

When I click Install, it changes to “Installing” and never offers and feedback that it finished.

From the terminal, I was able to verify that the certificate DID install and web access via https shows the correct certificate.

So it seems to be a bug with the Sys Admin module.

Since it sounds like it’s repeatable, it would make sense to file a ticket through the “Issues” tab at the top of the page. Without that, it’s possible that the bug will not get the attention it deserves.

Thanks,
I added a comment to the issue ticket already created by @frankb

The exact same thing happens to me, FreePBX 13 , GoDaddy certificate, I upload the new certificate without any error, but when I try to install it, shows this message:

Whoops\Exception\ErrorException
Undefined offset: 1
File:/var/www/html/admin/modules/sysadmin/SSL.class.php:167

If you find the way to resolve it, post it please,

Thanks;