Issue cloning FreePBX14 systems

For the past few years I take a FreePBX13 image then using Clonezilla install it on a new system. I’m starting to work with FreePBX14 and when I clone my image it boots to a grub screen. Is there something in the FreePBX14 that would stop this process or did my initial FreePBX14 image have an issue?

Hi, I’ve the same issue. Grub Error on boot :

Minimal BASH like line editing is supported. For the first word, lists possible command completions. Anywhere else TAB lists possbile device or file completions.


Have you solved the situation ?

We have not solved it. We have a few images taken with Clonzilla that can be placed on new server but most images when placed on a new server just boot to bash. I’ve tried all sorts of variables relating to static ip, dhcp, registered vs not registered but wasn’t able to determine why most images are not usable.

Thank you for your answer.

So I have to make multiples images and suddenly, one will work ?

And someone from Sangoma could help us please ?

Making multiple images seems to be the only way but there is no rhyme or reason as to which will work. Someone from Sangoma did mention this could be due to sng7 which now factors in the UUID more so than in the past (Terrible explanation on my part) I’m not sure though why some images work then.

Its not a tool we use so we would not be much help to you sorry. The only real different in the old version and newer is move from RHEL 6 to RHEL 7 based. I would start with does it work on a stock CentOS 7 and start googling based on that since they are also based on RHEL 7. My guess is its something to do with the use of UUID for drive selection.

It is a tool I have used quite a bit, Before using it, I edit in my grub config file


Then edit /etc/fstab to remove the UUID’-s and use the ‘original’ references, then



Do you add this line? I do not see this in my grub.conf file

In debian’s /etc/default/grub it is there but commented out, Redhat might do things differently, but grub is independant of and runs before any OS boots. So just add if necessary.

1 Like

I really appreciate your help here. I’ve added the GRUB_DISABLE command but am wondering about the fstab file. Do I just delete the UUID lines? or do I need to replace them with something?


Created by anaconda on Wed Mar 14 14:47:30 2018

Accessible filesystems, by reference, are maintained under ‘/dev/disk’

See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info

UUID=514ba8a6-2c03-4682-85cb-a8f884b36a67 / ext4 defaults 1 1
UUID=66977919-621e-485b-b754-e0df16f2aabb /boot ext4 defaults 1 2
UUID=f1562a6a-3673-4ad2-8b05-e7535f4eb585 swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0

Again, its easier in Debian as it comments the /dev/sdx original partitions, but you can correlate UUID’s with physical partitions with


and replace for example

UUID=514ba8a6-2c03-4682-85cb-a8f884b36a67 / ext4 defaults 1 1


#UUID=514ba8a6-2c03-4682-85cb-a8f884b36a67 / ext4 defaults 1 1
/dev/sda1 / ext4 defaults 1 1

I thought I had it but the cloned system booted to grub. I went back to the original system that I had made the grub changes to and looked in the boot folder and instead of seeing the boot and boot2 folders I found this:


The system did boot though which surprises me a bit. The changes I made in the fstab and default/grub still exist.

Did you update-grub?

1 Like

I tried to run the update-grub but that must be a debian command. I thought a reboot would update grub but it seems I was wrong there. I’ll figure out what it is for Centos and run that. Thanks!

I think this is a Centos 7 substitute for update-grub

grub2-mkconfig –o /boot/grub2/grub.cfg

Did you manage to get this working in the end?

I just used Clonezilla to clone our PBXact (freepbx) disk and restored it to a more powerful PC, but the system won’t boot. I either get stuck at the grub prompt (this is if I restore the clone with UEFI disabled), or I end up with a dracut:/ emergency mode prompt (this is if I disable UEFI and I actually get the Sangoma Linux 7 booting but it times out and I get the dracut after a while).

I tried adding “GRUB_DISABLE_LINUX_UUID=true” to /etc/grub.conf and deleting the UUIDs from /etc/fstab and then running “grub2-mkconfig –o /boot/grub2/grub.cfg”
But I still end up in draco emergency prompt thingy.

Anything else to try? Seems like we won’t be able to use Clonezilla to clone FreePBX anymore cos of this UUID issue :confused: I will try doing a restore of the backup if I can’t fix the clone I guess…

Any help would be appreciated.



I never found a solution to this problem. The vast majority of images taken of FreePBX14 using Clonezilla boot to grub. For some reason I have one image that is restorable. How that one image works I have no idea.

I bought a disk cloner from BestlinkNetware for about $30 that makes an image clone of a 1TB disk in about 15 minutes. I used it to create a “backup” for my Tivo before I started hacking the Linux on there.

Damn, no hope for me then :confused: I’ve resorted to installing FreePBX from scratch, turning it into PBXact and then restoring the backup… hopefully it works, but I am quite sceptical as I had issues before with using the builtin backup & restore :s
Cloning would definitely be a lot easier and quicker…Let me know if you ever find a cloning tool that works with the new FreePBX and all this UUID stuff.