ISO post install - no System Admin Module under Admin

I installed FreePbx 12.BETA 6.12.65-14. I have encountered a few problems which prevent me from configuring the PBX.

I wanted to change my IP to static, but the System Admin Module choice is not in the Admin drop-down.

Additionally, there is a Security Warning at the top middle of the screen after logging in.

The menu bar at the top right has a red button “Apply Config”. When I push the button, I get the following error:

   exit: 255
   PHP Fatal error:  Uncaught exception 'Exception' with message 'Unable to find key' in /var/www/html/admin/libraries/BMO/GPG.class.php:200
    Stack trace:
        #0 /var/www/html/admin/libraries/BMO/GPG.class.php(210): GPG->getKey()
        #1 /var/lib/asterisk/bin/retrieve_conf(20): GPG->trustFreePBX()
        #2 {main}
         thrown in /var/www/html/admin/libraries/BMO/GPG.class.php on line 200

Any suggestions on how I might correct these issues?

Thanks Lars

Do you have internet? Unable to Find Key means it can’t connect to the remote key servers at all.

Yes, you were right, no internet. I tried nslookup and got nothing.

When I installed I chose to manually set ipv4. I think that’s where I hosed it.

Anyway, I re-installed accepting DHCP and the FreePBX Admin screen has a lot of stuff on it. And the Admin drop-down includes System Admin this time.

Thanks for pointing me in the right direction. Lars

1 Like

I tried to change from the DHCP address to static, but it was not saved. I think the problem is related to the box having two NIC cards, eth0 and eth1. The first time I installed FreePBX, I used a static IP address for eth1. Perhaps I entered something incorrectly in this screen.

When I installed the second time accepting DHCP, I got to the System Admin, Network Settings, changed the drop-down to eth1 and entered the pertinent data. However, the configuration was not changed after pushing the Save Config button.

So I went to the console and ran system-config-network. It was still set to DHCP! I changed the data and ran ‘service network restart’ and all was well.

There must be a problem when two NIC cards exist.