Isnt it possible to interrupt the IVR when pressing somthing?

All i am trying to achive is an “normal ivr”

I set the Inbound Route to Point main IVR and then the FreepBX saying the Announcment.

The problem is that when i try to click on the number before the annoucments ends, it wont work.
only after the aanoucment ended.

What happans if someonw knows the numbers allready, i am not talking about the extention i am talking about the digit to go next ivr.

2)isnt it possible to do somthing please wait when a digit or extenetion is pressed?

  1. Is it possible to show the caller phone number from PSTN Line ?

How many times you going to ask this question?

DTMF should interrupt the message.

Hi,

I didnt get an answer,
nayway, really dont know what DTMF is, Can you provide short explnantion?
From what i read it seem it will not work with all phones, cellphones/line phones

what do you suggest

DTMF, touch tones. The buttons on your phones.

I see, Thank you.

Could you forward me to article or configuration that explains how to set it correct with DHADI? My calls are coming from PSTN Lines.

My Setup is:

  •   FreePBX Distro fully updated.
    
  • DIGUIM AEX410 CARD with modules below:
    o DIGUIM VPMADT032 - Echo Cancellation Module
    o 2 X Digium 1S110MF (FXS)- Single Channel Station (FXS) Module
    o 2 X Digium 1X100MF (FXO) - Single Channel Trunk (FXO) Module

the phones in the company, Cisco SPA500 Series, GrandStream2100, GrandStream2200

the IVRs are only for Incoming calls that coming from the analog lines.

we are company, it means people can dial to us from normal phones at home or cell phones.

What do you suggest?

I suggest you test your IVR internally first, make sure you can interrupt it from a keypress from the Cisco SPA.

Once you have eliminated that data point you have many things could be wrong with DAHDI but more than likely levels.

Have you Google’d DAHDI and DTMF on POTS lines and read up on how other users faced this issue? Have you read the DAHDI documentation? Do you know how to turn on DTMF debug so you can see what digits Asterisk “sees”. It’s in the Asterisk documentation.

If you just want the problem fixed that’s what paid support is for. If you want to work on a solution together then you need to read the docs and participate in the troubleshooting process.

I had.

I have already Set the DEBUG hours ago. It seem Astrisk sometimes ignores digits and in most times doesn’t detect them at all, i spend many hours on figuring it out.

I added also the following settings to chan_dahdi_general.conf
mindtmfgap=45
mindtmfduration=80
mindtmfinterval=200
dtmf=inband

it doesnt help also, i am now trying to use fxotune, maby this will help… do you suggest somthing else, or you think i am doing all wrong

well, I also tried to manage the choo cancellation

I added this to system.conf of dhadi
echocanceller=hwec,1

after reading http://kb.digium.com/articles/Troubleshooting/General-Echo-HOWTO

Just A little guide if you may Sir.
do i need to run the fxotune if i have hardware cancellation?
I also tried to run it, eventho i try to run it
i get:
[[email protected] ~]# fxotune -i -n 1 -e 1 -p
/dev/dahdi/1 absent: No such file or directory

I closed asterisk, still get it…

dont tell me what to do… i understand you… just tell me what do you think is the problem? the echo ?

Yes, the FXOtune is a good way to go. Levels can be too loud and overwhelm the decoder. I would also try turning off the EC and see if that helps.

I know some cards have hardware DTMF options.

I have heard there are hardware devices that can handle that
Can you suggest on one of them?

I dont see caller phone number + also somthing that handles dtmf

SO SKY, it seem to work good now. its hell alot of try/error
actully fxotune fixed it.

but the thing is it was hard to run fxotune, since it needed to be run while dhadi up

if you “fxotune -i -n 4 -b 1 -e 1 -p -vvv” run at first you will get
"/dev/dahdi/1 absent: Device or resource busy"

now after you turn off you and try run it you get
"/dev/dahdi/1 absent: No such file or directory"

the only way for this to work is to run dahdi solo, without freepbx or astrisk

/etc/init.d/dahdi start

then

fxotune -i -n 4 -b 1 -e 1 -p -vvv

too but i could not find anyone who experienced this.

another thing is to turn off the hardware echo, for some reason when i used dhadi_genconf, to see if its up
i saw all the time “(EC: VPMOCT032 - INACTIVE)” in dhadi-channels

i saw some error in asterisk, its was reported but not fixed, i guess i can safely ignore this issue, because this file is not in used anyway, so i deleted it.
but to turn the on the hardware echo, yes. i had go to diguim site and see, and in Free-PBX dahdi-> system settings i added echocanceller = HWEC,1,3

this after dahdi_cfg -vvv, i edited system naunally but i noticed freepbx can overwrite it, so i added in gui, correct?

it seem the only way to check if the hardware echo is on is by “dahdi show channel”

anyway everything seem to work ok now, but i still having major issue, which seem it doesnt have answer really
I cant see Caller phone at my sip phones, calles that are coming from pstn lines are allways shown as "unkown"
I tried all the options like that did here “http://www.freepbx.org/forum/freepbx/users/caller-id-not-working

I am releasing that my provider isnt support caller id somehow, but my question for you is. how i am suppose to know if its carrying caller id or not?
Well, i guess i gonnna plug normal phone into the pstn line and see if i get one…

Glad you got it working. FreePBX doesn’t run any binary so there is no stopping FreePBX.

To me it seems intuitively obvious you have to stop Asterisk since it has control of the channels.

Try the test phone if it works we have some options.

I used DAHDI module for the first time today so I can’t comment on adding extra variables. I have been configuring DAHDI (ne zaptel) for so long the GUI seems to get in my way. I tried the DAHDI module on a new system and it worked great.