IP settings headaches

I’m having a devil of a time getting my IP settings to work. When I perform a clean install I never pull a DHCP address. So I log into the console and manually edit /etc/sysconfig/network-scripts/ifcfg-eth0 This is my basic setup


and then manually build the /etc/resolv.conf file with

Quad9 is an IBM based DNS

If I am on the same segment, say (/28) I can access the gui and ssh. Anywhere else I cannot access. My phones outside of the segment don’t attach. While connected remotely (again inside the segment) to the gui I can’t use the SIPstation module because it says ‘no Internet connected’. When connected via ssh I also can’t ping a DNS entry or an IP outside.

My ISP gave me a few IPs to use. When I change the static IP via the gui it rips out a lot of my details. One thing I read was that lack of HWADDR can cause problems in CentOS, that doesn’t seem to change my issue.

Under Settings> Asterisk SIP Settings> NAT Settings> External Settings if I chose ‘Detect’ it fails; if I manually add the public IP still no change.

Also, enabling/disabling the firewall has no effect.
The Freepbx gui generates

# FreePBX Sysadmin Generated network configuration.
# This file was generated at 2023-03-13T20:21:18+00:00

Which does add the ‘ZONE=external’.

And just FYI, the 55.66 octets are bogus.

If I traceroute a known working IP I get 21 lines of * * * then on the 22nd line it shows

It really does seem like a bad gateway. I can’t get out of the local segment or to a DNS query. Yet I have a router at with the same gateway that works fine for Internet/VPN/whatever. I did double check with subnet-calculator and the /28 or .240 has .209 in its range.

As mentioned changing .219 to .218 makes no difference. I did this as a test in case the .219 that was given to me by my ISP was used by someone else.

More randomness

  • I installed 3 different times, used both 2302-1 and 2203-02
  • the hardware is an HP 600 G1 Mini with an Intel NIC, 8GB RAM, HDD, i5-4130T, BIOS is updated to 2.33 to remove some of the old Intel CPU security holes
  • initial install is on my LAN
  • none of the installs pull an IP (dhcp); dhcp server works fine for other 20+ devices on network
  • attaching a SIP phone connects immediately when both PBX+phone are on the same LAN (i.e. 10.200.80.x /24)
  • attaching a SIP phone connects immediately when both are on the same segment (i.e. /28); although the Dashboard shows those phones drop off after awhile, if I reboot the phone the Dashboard shows the connection re-established
  • I know boot-up has a 10min wait for Asterisk, but should shutdown take 10-20mins?

Oy, so I’m on my home lab now. I installed on different hardware thinking maybe the NIC in the HP 600G1 was flaky. This time an old AMD5350 AM1I mobo, with a Realtek NIC I think. Same thing, the install would not see the NIC on boot. I tried an
ifdown eth0
ifup eth0
no change. I then edited the ifcfg-eth0 file by deleting all references to IP v6. Another reboot and this time the FreePBX pulled a LAN IP (10.200.80.x) and I could activate the install.

Once inside the gui I changed the settings to a spare public static IP I have. On reboot, it pulled a DHCP from my ISP, completely ignoring my settings. I verified that BOOTPROTO=static. Another
ifdown eth0
ifup eth0
and now the PBX at least shows the correct public IP. I could get into PBX initially but now I can’t. Thinking maybe the firewall kicked on, at the console I
fwconsole firewall add trusted
the service seemed to accept that but still no access.

A reboot and I was able to log into the gui. I hopped over to the firewall and it is in a disabled state. I figured I may as well enable it and make sure to add my home lab ( Well, good intentions… I clicked on the ‘enable’ option on firewall and now I’m back at the no access/no web page here.

I logged into the console and now it shows IP addresses of 1) my static from ifcfg-eth0 2) the DHCP came back and 3) an IP v6. Another ifdown+ifup and at least the ISP DHCP disappears again. Yes, it was the same DHCP as before. Still no access to the public though.

Is 2302-1 considered stable? Granted I used to use more FreePBX years back, v12-v14 mostly. But should it be this hard to get a system that boots properly? About 6-12 months back I installed FreePBX on a Pi 3+ just for the house. It was not that difficult. This is the ‘main’ release on extremely basic hardware. Has there been some complete rewrite/re-implementation of the networking piece that I’m missing?

Still thinking something to do with the firewall, I
fwconsole firewall disable
and get a ‘firewall is not enabled, can’t disable’ msg. Oh well, bedtime.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.