IP Phone, plug and play

I have had many issues with trying to get two cisco IP phones to work with freepbx. I can’t get them to work, but I am still looking to use the freepbx distro.

I found the compatibility list, but noticed that some are not confirmed to work or still require some tweaks to work.

Are there phones that just work with freepbx? Meaning, I plug it in, it communicates with freepbx and just works…

I am still looking to use my Google Voice trunk for calls in/out (which is currently working when I use a soft phone).


AASTRA, Yealink, just to name a couple that work well with the EPM. You’re not going to have a phone that “just plugs in and works”. You’re going to have to set up the extension in FreePBX, and one way or another you’ll have to set up the phone.


Thanks. Sorry, I should have added that to my first post. Yes, I do realize that I will have to setup the phone in freepbx, that part is not the problem with the cisco phones.

What I meant was…I am looking for a phone/brands that will play nice with freepbx. Meaning, after I setup the user name, extension, the basics… it just works with the current trunk I have setup.

Have you used any Aastra/Yealink phones that work well with the system?

I am going to start with those two brands and I will probably post the ones that I like in this thread hoping that someone has had good luck with whatever I end up going with.

Thank You.

This one looks like it will work with freepbx. It is in the endpoint manager on the freepbx distro I am running (not the current release). The cisco phones were also in the endpoint manager, but those gave me some issues. I am going to confirm this phone works (easier than the cisco phones) before I pull the trigger.

I have used Yealink T28, T38G easily as well as SNOM 320 and 370.
I prefer the T38s out of all of them now.
Hope this helps.

All phones that show full supported and tested in the EPM wiki are easy plug and play setup for FreePBX using the Commercial EPM.

As someone that has over 225 devices in his office I still like the Aastra 6757, 6737 and 6739i phones over everything else out their. The yealinks would be next but I still put the Aastra ahead of Yealink.

When you say Cisco what model are you referring to? The Cisco Small business stuff or the Enterprise?

Isn’t there a price of $25.00 for the EPM in the latest version of the freepbx distro?

The version I am running has the free endpoint manager.

PBX Firmware: 1.1010.210.62-3
PBX Service Pack:

I am really considering the yealink sip-t28p.

7961g and 7970

I can’t get either of them to work and one of them is listed in the EPM. I had a member from the board PM me and remote into my system. He has working cisco phones, but was not able to get mine to work. He tried everything from scratch, he even copy/pasted his own config files and was not able to get them to register.

I made some progress with the 7961g, but I was not able to get it to register.

That looks nice, but a bit too much money for one unit.

I bought a yealink t28p and it arrived today. I set it up in the EPM (free version, not commercial) and I kept seeing a red circle.

I logged into the phone and made some changes via the web gui. Still a red circle. I am 99% positive I didn’t make any changed in the freepbx server, but I clicked around a lot. I did reboot the freepbx server and checked EPM and saw that the red circle was now green.

Calling in and out using Google Voice is working.

There are a few things I don’t like about the yealink phone, but overall I am happy with the purchase.

Ok, just rebooted the phone and server to make sure everything registers. The phone did an upgrade, I assume it is pulling from freepbx EPM, now. I can no longer login to the phone via the web, again, I assume freepbx took over that function.

Calling in/out works with Google Voice, so that’s good, but now all 6 of the lines on the phone show up as my main 1000 extension.

The EPM changes the password to the value set in the global settings.


Thanks Bill, I am still figuring out what everything does, I am a total rookie.

I figured out that I applied a custom template to it, It was just one of the options in the drop down under EPM, unless I did something to create a template…? Still learning.

It looks like the default template has all 6 line buttons set to line by default, which explains seeing 1 active line to 6 active lines. I am changing that now, and rebooting.

So far everything seems to be functioning, I am sure there is a lot that I am not doing/missing/etc…

Is it possible to pull from an online address book, for example, my gmail.com address book?

I saw a place where I can upload a csv file, which is better than nothing.

I want to figure out how to get additional rings on here, if possible.

I see the web password option, it is blank by default. I populated it and rebooted the phone. After it rebooted, the password I set worked to get into the web gui.

It takes about 2 minutes to boot the phone, register, etc… that seems a little long, but it does end up registering.

I am having a similar problem. When provisioned the EPM changes my GUI pass to something unknown how / where did you find the global password option that the EPM sends.

by default it was blank. i just entered in a password, saved, and rebooted the phone and it accepted the new password.

login to the pbx gui, click on connectivity, oss endpoint template manager, fill in this field “Web administration password:”

Thanks, but I don’t see that field anywhere in the endpoint manager settings. I am using the version that comes with my Xorcom PBX. I’ll keep looking.

How do you use the End Point Configuration Manager to change the 6 lines to something else? I’m having trouble getting the codes to dial correctly. There’s probably a better way to do what I’m trying to do.

Specifically, I’m looking to set up four users to pick up a fifth extension. When an incoming caller dials 0, extension 600 rings. Four customer service reps hear the ring and execute a Directed Call Pickup via **600. I can’t get FreePBX ECM to configure the codes correctly. I assume I’m looking to configure a BLF event. Any advice or comments?

Specs: Yealink T-28, FreePBX, and free OSS End Point Configuration Manager, Yealink/Dreamwave (Package Last Modified [9-13-12 at 2:01pm])