"Invalid Trunk Name Entered" - can't create any trunk

Newbie here, but I’ve played around with Asterisk, Trixbox, PIAF, FreePBX over the years. I’ve just installed the newest version of PIAF Incredible PBX (Purple). I attempted to add a new voip.ms SIP trunk, through FreePBX of course, but when I tried to save it I received an error stating “Invalid Trunk Name Entered”. So I tried another name, and got the same error. In order to try to get the trunk up and working I chose to try to edit, in FreePBX, the unused ‘sipgate’ trunk which had been automatically created when I installed PIAF. I edited the required info and changed the name from ‘sipgate’ to ‘voipms’ and saved it without any problem and the trunk works. But since then I have tried to create other SIP trunks and repeatedly receive the “Invalid Trunk Name Entered” error no matter what name I choose to call it. Bottom line is that I am unable to create any trunks. I have no clue as to where to start to troubleshoot this problem. Any and all help/advice would be much appreciated.


Giant brain fart here. I had repeatedly overlooked the fact that Trunk Name had to appear in 2 places. All is well.

1 Like

Can you point out the second place, because I am experiencing the same issue here. Thank you!

Any luck? I don’t see a 2nd field either and am having this precise problem on FreePBX

It’s under the “Outgoing Settings” and above the “PEER Settings” options in the form.