FreePBX | Register | Issues | Wiki | Portal | Support

Internet provider changed - problems with remote extensions


(Jam) #1

Hey all,

I’m completely new to voip, but I’m currently the only tech guy at my company, so when anything goes wrong it falls to me.

We have a voip server running FreePBX 14.0.3.2 here in the office, and 10+ phones here on the local network. Mostly Polycom SoundPoint 331s. We also have three employees that work from home, and they each have a Polycom SoundPoint 331 which connect to our server and take part in the whole thing.

Our office changed internet provider a couple days ago, and immediately those remote phones lost connection. I got them back online by having them change the ip addresses of the SIP server and the outbound proxy to point to our new ip address. That makes sense.

However, after the initial jubilation, it became apparent that all calls over these phones are dropping out after about 30 seconds, and now one of them says she isn’t receiving any calls at all. I’ve been reading around, and perhaps the call dropping is due to failing to receive call acknowledgement? But why would the one phone not be receiving calls at all any more?

I’m at my wits end here, especially because I didn’t set this system up and I have a lot on my plate at the moment anyway. So any direction or advice would be welcome!

Many thanks.

edit: I’d love to look at the asterisk log and learn something about this. If I could filter for something in particular, that would be brilliant, but I don’t know what I’m looking for. Any ideas?


(Tom Ray) #2

Did you make sure or check that the routers/firewalls where the remote phones are have the proper information due to the ISP change?

People tend to forget that if the PBX is in one location behind NAT and the phones are at another location behind NAT that they have to make the needed NAT rules/updates on both sides.


(Jam) #3

I spoke to the employee on extension 113, which is one of the remote extensions that’s playing up. She told me she never had to log into the router when she set the phone up, she just plugged in the phone, got the local network settings right, and it worked. I also asked her to log in, and from her description, there didn’t seem to be anything relevant in the router control panel.

I’ve been looking at the asterisk logfiles, and I found a few lines that might be interesting:
[2018-11-09 10:09:20] VERBOSE[23200] res_pjsip_registrar.c: Added contact ‘sip:113@***.***.***.***:5060’ to AOR ‘113’ with expiration of 3600 seconds
[2018-11-09 10:09:20] VERBOSE[2686] res_pjsip/pjsip_configuration.c: Contact 113/sip:113@***.***.***.***:5060 has been created
[2018-11-09 10:09:20] VERBOSE[2686] res_pjsip/pjsip_configuration.c: Endpoint 113 is now Reachable
[2018-11-09 10:09:23] VERBOSE[2686] res_pjsip/pjsip_configuration.c: Contact 113/sip:113@***.***.***.***:5060 is now Unreachable. RTT: 0.000 msec
[2018-11-09 10:09:23] VERBOSE[2686] res_pjsip/pjsip_configuration.c: Endpoint 113 is now Unreachable

Any thoughts?

We logged into the phone and changed a few settings, but nothing helped. We changed:
(Under NAT settings): Keep-Alive Interval changed from 0 to 20 (0 meaning never send keep alive messages)
And updated a config file that still had the old ip address of the pbx server.

I’ve also changed RTP keep-alive to 20s under CHAN SIP settings, and for the extension in question I changed Qualify Frequency to 20s in extension settings. (Did this based on some other forum posts) Anyway, still no good.

The extension settings have an option that says “Change CHAN_SIP driver”, so maybe the “rtp keep alive” setting isn’t going to help unless I hit this button? I’ll give it a try.


(Tom Ray) #4

The endpoint going UNREACHABLE means the PBX isnt getting replies to KEEPALIVES to the phone. That is a NAT issue


(Jam) #5

Ok, that makes sense.
Here’s some of my assumptions/conclusions that I need help verifying:

  1. The employees never configured anything on their routers. Therefore there can’t be anything on the router that needs to be reconfigured.
  2. The employees probably have dynamic IP addresses. The only NAT setting I can find in the phone is this:
    phone%20nat%20settings
    As far as I can tell, this is meant to hold the ip address for finding the phone across the internet. But if this is a dynamic ip address, there’s no point in putting something here.

How does the pbx server ever find an extension with a dynamic ip address? The extension must regularly update the server with it’s public facing ip address, no?


(Tom Ray) #6

The PBX is going to send an OPTIONS packet to the phone, like it always has. The PBX will wait for 2 seconds for a reply to that packet. If it doesn’t get a reply, it re-transmits it. It will do this 7 times and then it will move the device/endpoint to UNREACHABLE. When the phone re-registers it makes it AVAILABLE again but the process starts all over.

So either the remote phone is not getting the packet OR your modem/router (new due to the ISP change) is not passing the reply through properly to the PBX. Either way, it’s a NAT issue. Now if the remote users never had a problem before and this only happened after the ISP change then whatever equipment that was put into place is either running a firewall, NAT or other things like ALG that could be causing this issue.

I’d focus on what was changed at your location with the PBX.


(Jam) #7

Makes sense.
I went to speak to the company who runs the building, and changed the internet provider, and naturally their entire IT team is absent today. I will find out more on monday! Though I did find out that they have no new equipment - same switch as before, etc.
Many thanks for your help so far.


(Jam) #8

SOLVED!

You know what I needed to do? Restart the PBX. I think this was needed in order for it to operate with the new ip address in mind. Perhaps when an extension connects, it sends the ip address it thinks it has to that extension, and the phone tries to reply to that ip address, rather than the one it used to connect in the first place?