Internal calls connect, but no audio

I’m not sure if it is related to my host, but I cannot hear anything when calling extensions.

There is no NAT, as it is a hosted server with a static IP. The only difference that I can see from my home lab is that in the Asterisk SIP Settings, the option for “Default TLS Port Assignment” is greyed out, where in my lab Chan SIP is defaulted. I don’t think that is it, as I am only using PJSIP connections anyways.

I don’t have a trunk installed on this PBX yet, as I can’t get the internal calls to work. Can anyone point me in the right direction?

It has something to do with freepbx setting the contact / connection to instead of the IP of the FPBX server… anyone know where to fix that?

holy crap… for some reason putting in my fqdn made it think the calls were to go to (I only figured this out because the awesome support at – John the amazing tech) noticed the responses were going to

Once I updated my fqdn to my static IP, it worked fine!.. what in the world??? Why does the fqdn send to the trunk to respond to???

Do you have the hostname of the system set to that FQDN? That would do it.

I do have the hostname set to that fqdn… The hosts file isn’t set to Even then why would it send that address to the trunk to respond to.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.