Internal call, but rtp goes to 104.145.12.182:5060


(James Zhu) #1

hello:
I installed freepbx-15 to test in china, make sip call between two extensions(PJSIP)with LAN, but the rtp address is from 104.145.12.182:5060. no RTP at all. It is a Canada public address. Anyone has such issue?
-----------------log------------------------
Server: FPBX-15.0.16.72(16.11.1)

Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER

Contact: sip:104.145.12.182:5060

Supported: 100rel, timer, replaces, norefersub

P-Asserted-Identity: “100” sip:100@192.168.1.57

Content-Type: application/sdp

Content-Length: 289

v=0

o=- 1605001142 1605001144 IN IP4 104.145.12.182

s=Asterisk

c=IN IP4 104.145.12.182

t=0 0

m=audio 17352 RTP/AVP 0 8 9 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:9 G722/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=maxptime:150

a=sendrecv


#2

Not enough logs but Allstream is a Canadian VOIP provider that was bought by Zayo that also owns lots of other VOIP providers. Who is your VSP for any of your tunks. sngrep should show more details


(James Zhu) #3

just install in my office only, and make two exten calls, no vice ant all and find the address, I do not create any SIP trunk.


#4

sngrep show what for the INVITE?


(James Zhu) #5

image , please refer this:
https://wiki.freepbx.org/display/SBC/Standard+SIPStation+Configuration


#6

In Asterisk SIP Settings, the default value of External Address is Sangoma’s.

For the system to be usable, you must correctly set External Address and Local Networks.

Usually, the Detect Network Settings button will do that. Otherwise, set them manually.

Submit, Apply Config, Restart Asterisk, test.


(James Zhu) #7

thanks, I will check.I never saw this problem with other versions before.:joy:


(James Zhu) #8

thanks, I changed and reboot, it works.


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.