Intermittent one way audio on local LAN (no NAT) when using SNOM PA1 and Ringgroups/FMFM

Seems like FreePBX/Asterisk box is intermittently not relaying the RTP stream from a Snom PA1 door intercom to Snom 710 extension phone.

Installed FreePBX (on dedicated on site Dell Server) and Snom phones last year, all has been working fine since. Recently tried installing a Snom PA1 as a door intercom. Basically just a Snom phone in a box with a loudspeaker, microphone plugged in and relays for the door. Person at door presses a button, the PA1 dials a ringgroup, the ringgroup dials some extensions, somebody answers, lets the person in by pressing 1# (this activates relay 1 for several seconds). I have 7 buttons on the door and created 7 ring groups (one for each button). Some buttons just call one phone and some call multiple using the ‘ringall’ strategy. Other benefit of using a ringgroup it can be set to just terminate the call after 20 seconds rather than go to answerphone which we dont want.

So I get the sytem in place and all seems to be working fine, then I start getting complaints that sometimes it isn’t working, the person picking up the phone cannot hear the person at the door (but the person at the door can hear them). So I set call recording up on all the ring groups, ensure Asterisk is logging, and I also setup a monitor port on our switch so I can capture all packets going to and from the FreePBX box using Wireshark on another server. The results are below and this is where I get stuck… the only thing I can spot is that the FreePBX box is not relaying the RTP stream from the intercom to the phone, but is relaying the stream from the phone to the intercom just fine. I have also tried using a dummy extension and FM/FM instead of a ringgroup and still have the same problem. The data below is using a dummy extension 364 and FM/FM.

Some information:

PA1 Intercom : ext 401 Name: KC Door IP: FWver: snomPA1-SIP
710 Phone : ext 416 Name: John Dixon IP: FWver: snom710-SIP
DummyExt : ext 364 FM/FM to extension 416
FreePBX : IP: FWver: / 12.7.5-1807-1.sng7

Allowed CODECs on Snom devices (Snom defaults):

Allowed CODECs on FreePBX:

Don’t think it’s a CODEC problem as all other devices have been working fine and according to the Wireshark logs the PA1 ia correctly sending g711U to the correct FreePBX port. The RTP audio stream from the intercom decodes fine in Wireshark (you can hear it) but the call recording in FreePBX does not have this audio, it only records the audio from the phone (ext416) not from the intercom (ext401).

All are connected to the same LAN switch in the same building.

Please see attached logs… remember this is an intermittent problem, sometimes it works OK, sometimes it doesn’t. It always seems to work fine on an evening when I am in on my own testing, but not so much during the day when people are in the offices! Not sure if that is scientific!

The files with “working” are from a time when it worked just fine, the files with “not working” are from a time when it didn’t work, but all other things being equal.

Any help greatly appreciated as it’s driving me nuts! Cheers!

Something I have noticed…

Although the Snom devices have STUN disabled in the settings, they are still sending out STUN requests. The Snom devices initiate the requests. The Dell server responds in about 200 MICRO seconds, The Snom 710 responds in about 120 MILLI seconds and the PA1 takes about 250 MILLI seconds to respond. This seems like quite a long time to me?

Is it possible that Asterisk is sometimes timing out on the request and therefore not relaying the RTP?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.