Intermittent incoming and outgoing calls

This is our most pressing issue - Our FreePBX is setup and the softphones clients (Linphone) are registering successfully. Incoming and outgoing calls sound fine when they work; but most fail. The calls to and from each phone fail far more than they succeed. When the calls work, we hear a slow beep as soon as the number is dialed indicating the receiving line is “ringing”. Most of the time, when a call is placed, the linphone client looks like it is trying to place the call; but it remains silent and then the client gives an “unknown error - request timeout” pop up message.

Also, a side note, we can call each other (when the calls work) when all clients are off the LAN that the FreePBX server is on; but we cannot call clients on the LAN. All clients on the same LAN as the FreePBX server can call each other consistently; but this of little use to our use case. Is there a way to make the LAN and WAN clients be able to call each other? Are these two issues at all related? I doubt it; but it nevers hurts to provide more info. Thanks to anyone who can provide some input.

This part sounds like you are not properly compensating for NAT. The preferred way of solving his for internal calls is to use VPNs, and let SIP work in a real, untranslated, IP network environment. However, failing that, you should disable direct media, then look to re-enabling it in a more nuances way. You should make sure that FreePBX knows its public IP address, and, as far as possible, also do the same for the clients. You may need to enable the force rport and symmetric RTP options, which selectively violate the protocol in ways that can help where the remote side is behind a (different) NAT. However, I think FreePBX defaults that way.

Given media works once connected, and that FreePBX tends to frustrate direct meidia, I would probably rule out overloading of the FreePBX machine (assuming it is real and more powerful than a Raspberry Pi). That would suggest some sort of network or firewall issue. (On the other hand, your second part could indicate that you are getting direct media.)

Thanks for your input. What is meant by “direct media”? My apologies for the potentially silly question. I just started using FreePBX about 48 hours ago when I initially set it up. So, this is a whole new world for me. FreePBX has its WAN IP set in its configuration; and all clients are connecting to the server over the internet via a domain name in this way “”. So, all clients are reached via this address scheme “[email protected]:1111”, “[email protected]:1111”, and so on. Also, RTP ports 10001-20000 are forwarded to the server through the router. I’ll look into “force rport and symmetric RTP options”. The FreePBX server has 6GB ram and 8 CPU cores.

Any idea why the softphone clients have so many failed sent/received calls? What softphone software does everyone recommend for android?

Direct media means when the speech goes direct form “client” to “client”, or directly between “client” and “trunk”.

I’ve assumed that you are using the supported SIP channel driver (chan_pjsiip), however there is a lot of obsolete documentation, for the deprecated driver, that refers to direct media by a long deprecated name: canreinvite.

force rport and symmetric media are also referenced differently in the deprecated driver.

It’s not completely clear to me what resolves to, but the phones on the same LAN as the PABX should be using the LAN address, not the WAN address.

Thanks for clarifying. Yes, I am using pjsip and the LAN clients are using the LAN address instead of the domain name. The I referenced is an example. The actual DNS name I am using does resolve to the WAN IP that is configured in FreePBX. I run many services successfully and all softphone clients register and remain connected. So, I know the networking is configured correctly.

I think the NAT issues are a problem with the perimeter router I am using, not a FreePBX issue.

The main issue is why clients fail to send and receive calls so much more often than they succeed. The server’s resources are more than adequate. I would think they’d always fail if the configuration was bad; but I’m super-noob here so I could be totally wrong. Is there a call limit per client that could be causing this? Maybe our short test calls are getting hung up and preventing follow up calls? I doubt that is the issue; but I’m just throwing out random ideas here. Could the Linphone softphone be the issue? Can you recommend a better softphone that can work on Android devices?

Good news everyone! The Linphone client was the issue. So, if you have these same issues, try using Zoiper (the only client we have tried that has worked consistently on android so far). I welcome recommendations for any clients anyone has experience with. Are there any security or privacy issues with using Zoiper? I see it collects google analytics data by default. That can be disabled (supposedly) in the settings > advanced menu.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.