FreePBX | Register | Issues | Wiki | Portal | Support

Intermittent delayed incoming calls


(Jlong) #1

Hello,
Having a bit of a strange issue that I can’t find a solution discussed in the forums.

Issue: intermittent delay before IVR picks up.

Sometimes the delay can be up to 17 seconds causing people to hang up and try again and sometimes it picks up on the first second of the call. My voip provide Ipcomms, says that they don’t see any drops in registrations on their end. I’ve noticed after the long silence it will answer correctly for awhile and then “fall asleep” again. There is no consistency to when it does or doesn’t work correctly. As I was trying to debug using -vvvvr I wouldn’t see any information on the screen until the ivr actually connected no errors or warnings beforehand.

We have a Comcast business modem / router

Things I have checked:

DNS settings
Disabled firewall on both router and freepbx
Tried plugging server directly into router avoiding switch.
Checked and rechecked network settings

Can anyone please point me in the right direction of other things I could check. I read something about it might have something to do with the cnam caller ID settings.

Thanks in advance!


#2

Is your freepbx behind NAT? If so, have you forwarded the needed ports?


(Dave Burgess) #3

Tell us more about how you’ve got your firewall set up. This sounds like an incoming NAT problem to me.


(Jlong) #4

I have NAT on the modem / router turned off. Also all firewalls are turned off.


(Lorne Gaetz) #5

Intermittent delay of the type described herein does not suggest NAT to me. I would suspect non-responsive DNS or STUN server(s).


(Dave Burgess) #6

The thing I keyed on was “once it works, it’s OK for a while, and then it stops again”. That sounds like a redirect timeout in the router. Now, it could also be an unresponsive DNS or STUN server (as pointed out), so both paths need to be followed.

You are going to have to tell us more about how your system is set up. You may need NAT set up in several places for this to work - or almost nowhere. The architecture of the network is going to be the clue as to how the NAT settings need to be arranged.


(Jlong) #7

Ok I figured it out. When somebody said Nat settings, I went back into the modem settings and really looked to see what I could have missed. It turned off UPnP and that resolved my issue! Thanks for pointing me in the right direction.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.