Interfacing FreePBX with another Phone system, Issues

I’ve setup a FreePBX installation in our office, to act as a SIP gateway for an existing phone system (LG IPECS).

In this configuration, the FreePBX machine has three trunks, one for a GSM gateway, and one for our VOIP provider, then one back to the IPECS system.

We have a DDI range assigned to the VOIP service, and these numbers arrive at FreePBX and need to be forwarded to the IPECS system.

To do this, i’ve created an inbound route for each DDI, pointing at a custom extension. This extension is numbered the same as the DDI, and its dial rule contains “SIP/ipecs/ddi” where ddi is the same as the extension number.

This works, incoming calls are correctly identified, and forwarded to the IPECS system, however i think we may have come across an issue. If there is an ongoing call to (for example) DDI 1234, and a second call comes in, also for DDI 1234, FreePBX sees the extension as “busy” and forwards the call to voicemail.

This isnt what we want, all calls coming in should be forwarded, and the IPECS box can handle the routing/ring groups/voicemail as appropriate.

Any ideas how to solve this??


The extensions you are using as forwarding extensions need to be of the “custom” type with no voicemail and call waiting on.

Any ideas folks?

To put it another way, we’re doing a trunk to trunk transfer, but we need to “Dial” the receiving trunk with a number that represents the DDI of the incoming call.


Ah, so your suggesting that as long as i have voicemail and call waiting turned off, they will act as intended?

I think voicemail was originally enabled on all of the extensions, however its now turned off.

Call waiting needs to be turned on.

It also needs to be a “custom” extension, not SIP or any other type.

They are “custom” extensions with manually keyed “Dial” entries, in the form shown above.

What does enabling call waiting do? I dont want the calls to sit in a queue, i just want them forwarded, theres plenty of capacity on the other phone system to answer the calls!


The style of call waiting interface is enabled on the endpoint. From the custom extensions standpoint if you enable call waiting it works with the concurrent call field to determine how many calls to send to the endpoint.

Nice! That sounds perfect, i shall test it out shortly.

I dont see a concurrent call field though, where do i find that?

I see “Outbound Concurrency Limit”, is that what i need? Its currently set to “no limit”

Yes, that is the field.