Intercom not working

i am stuck. can anyone help me solve the following problem?

I am new to freepbx and i am having a problem with getting the intercom to auto answer. i am using the polycom 560 phones and i am on the current version of freepbx. I have done the following so far:

-installed the paging and intercom
-installed the endpoint manager - i configured the phone using endpoint manager
-setup extensions - set Internal Auto Answer - to intercom
-i checked to make sure the alert info was in my sip files -

-enabled - Force All Internal Auto Answer
-Internal Auto Answer Default - set to intercom
-dialed *54 to enable the intercom on all the phones

when i dial *80502 from 501, 502 rings twice then it goes to a busy signal.

i setup a page group to see if i could get that to work. when i dial ext 1500(page group number) from 501 to the other two phone. 501 pickups but the other phones just ring twice and then just stops. 501 remain on a active phone call.

Everything else works so far. I can dial out, receive calls and i can dial other ext and answer them manually.

thanks in advanced for any help.


Polycoms features are enabled by the first file read. That feature will be ignored by the phone in subsequent files.
I attempted to use the endpoint manager for polycom but there were too many issues with polycom phones. Quite frankly, I had to abandon it. I found I had to edit the files manually.
You need to look at your config files, in order, to see where that

<alertInfo voIpProt.SIP.alertInfo.1.value="Ring Answer" voIpProt.SIP.alertInfo.1.class="4"/>

first appears.
I found it in the server_xxx.cfg file. It was over riding sip_xxx.cfg because it was read first.
If you look in URMACADDRESS.cfg, you will see what order the config files are read by the phone.
IMO, Polycom phones are a major PITA. It sucks, because they are nice phones. Just not very user / asterisk friendly (again that’s just my opinion).

I don’t think it’s a Polycom issue - I think it has something to do with Asterisk/FreePBX. I’m having the same problem, however all I have to do is restart (not just reload, but restart) Asterisk and the phones magically start to work correctly. Not sure for how long just yet - still experimenting…

Did you enable paging on your phones from the phones? *54 I believe, from each phone. Might make a difference… dunno.


i add the below to sip.cfg files manual before i switched to using the endpoint manager. the phone would work for about 45 mins then stop working. i could never get the the blf status and the intercom to work together, no matter what i did(manually editing sip.cfg). when manually enable the presence feature in the sip.cfg file the intercom would stop working. the alertinfo was in my sip.cfg when i tried manually. i just left it off in my post.

after switching to the endpoint manager.

if i ssh into the server and add the below code the intercom will work.( blf works to).

nano is the linux file editor. file to edit /etc/asterisk/extensions_custom.conf

nano /etc/asterisk/extensions_custom.conf

exten => 1502,1,SIPAddHeader(Alert-Info: Ring Answer)
exten => 1502,2,Set(Call-Info: ;answer-after=0)
exten => 1502,3,Set(__SIP_URI_OPTIONS=intercom=true)
exten => 1502,4,ChanIsAvail(SIP/502&SIP/1502,js)
exten => 1502,5,Macro(user-callerid,)
exten => 1502,6,Dial(Local/502@from-internal,A(beep),)

the above code is for extension 502.

i can add a 1+extension and the intercom work. you dont have to use the *80+ext. this is annoying becuase you have to add the above code for every extension. (i got this to work using the endpoint manager) i have not tried to get it to work manually editing the sip.cfg but i think it would work. my problem now is that i cant get the page all phones to work. if i call from from 501 to the other extenions it picks up on 501 but just rings the other extensions.

i have read that i might have to install dahdi. read the bottom of this post.

i dont know how to install and recompile this file. i am not that good at linux. can someone post how to do this.

thanks in advance

Figured it out. Paging module is detecting Polycom in [macro-autoanswer] and switching the Alert Info header to “info=Auto Answer”, which is (obviously) not the default “Ring Answer”. Not sure why they did that, as every Polycom tutorial on earth uses “Ring Answer”. In any event, all you have to do to fix is switch the line:

	voIpProt.SIP.alertInfo.1.value="Ring Answer"


	voIpProt.SIP.alertInfo.1.value="info=Auto Answer"

in your sip.cfg file (in endpoint manager - if you are still using it - or in the ftp/tftp root for your Polycom setup files), and paging will magically start to work.

i just replaced Ring Answer with Auto Answer. everything seems to work now.

I just wanted to confirm that the suggestions made by johnjces and jnetman1 are what ultimately solved this problem for me as well.
Thank you sirs.

To be clear,
I changed the /tftpboot/sip.cfg config from:
voIpProt.SIP.alertInfo.1.value="Ring Answer"
voIpProt.SIP.alertInfo.1.value=“info=Auto Answer”

I’ve been having other provisioning issues so I just reset the phones to default and formatted them to ensure they got the updates to sip.cfg.
Then I enabled the intercom on all phones by entering *54 .

I can now call my new pageAll extension I created and all I can hear my voice coming out of all of the speakers. I’ve still don’t like the sound of my own voice from the outside.