Intercom / Auto answer behavior

Hi everyone,

I am trying to get our phones to ring-thru after the receptionist announces the call and drops off. Right now, the transferred call just sits there on speakerphone. Does this make sense? This is how our current Toshiba system works. Auto answer is working great, just not the ring-thru with the caller.

We are using Grandstream 3240’s. It’s auto answer is set for Enable Intercom/Paging.

Trey Cooper

I don’t understand exactly what’s happening, but from my experience in scenarios like these, the easiest was to park and announce.

Two things are coming into play here:

  1. You have the phones in Auto-Intercom for Internal - this is not the default mode of operation, but it is supported.

  2. Default mode for the Grandstreams is Attended Transfer - you can force Blind, but I don’t think you will like the result.

Solution is simple - when the attendant is transferring the call, they need to hit transfer, and then the button switches to Blind - press it again, and then either dial the extension or hit the BLF and the call will appear as a ringing call at the extension.

Had to explain this to a Clinic just yesterday.

Hi Greg,

Thanks for your response. You are correct about #1. Auto-Intercom is enabled and works very well. On #2, I have set the Grandstream phone to default transfer mode to Attended Transfer Only (Advanced settings - Call Features - Default Transfer Mode) This takes away the blind/attended option and forces it to be attended.

I can hit transfer, extension, send and announce the call. When I hit END to drop off, the transferred caller is then on the speakerphone. I would like for the phone to ring and the person have to answer it, or let it ring thru to voice mail. Could I be missing a setting in FreePBX on transfered call behavior? There are so many setting…


Sorry that’s not how SIP transfers work. Once the phone auto answer it starts the transfer process. It can’t than hangup the auto answer and send the transfer after

I was afraid of that.

Is there a best practice for users that want their calls screened and announced before taking the call?

Have it ring and not auto answer.

Or Park It and then call the extension to announce - seems like a lot of work for the receptionist though.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.