Installing superfecta

I’m doing a from scratch install of freepbx, I’ll report back some suggestions and possible proces improvement once I’ve got it all working (to make sure some of my suggestions don’t come back round and bite me!). I set about installing superfecta today and followed the process at

When it tried to actually install the files, I got a Whoops:

Whoops \ Exception \ ErrorException (E_WARNING)
chmod(): No such file or directory


if (! function_exists("outn")) {
  function outn($text) {
	echo $text;

// Set execute permissions for AGI script
chmod(dirname(__FILE__) . '/superfecta.agi', 0755);

//a list of the columns that need to be included in the table. Functions below will add and delete columns as necessary.

I wonder if that line should be:

chmod(dirname(__FILE__).'/agi/superfecta.agi', 0755);

Sorry, scratch that - this is a really old version. The real question is therefore why the wiki page I found on google points to such an old version?

In fact, also points to old versions.

incidentally, I went the root of searching out official install instructions because superfecta didn’t appear on the list of available modules in Module Admin after an online check.

I tried the trick of then doing an online check (which then found the latest version) and clicking on install, but although it said it was going to install the latest version it actually tried to install the old version.

Finally sorted it by selecting every repository, apparently Superfecta is in ‘extended’. Perhaps the wiki pages should be updated to point to using module admin and selecting ‘extended’ before doing an online check?

Fixed. (padding for 20 chars)

Cool. Sorry to be picky, but the same comment should probably be added to:


[The second points to the first, but I suspect that both turn up in google searches …]