Installing SCCP


I have a Cisco 7940 (SIP firmware) and I have attached a Cisco 7914 Expansion Module to it but I get steady red light.

After googling, It seems that 7914 wont work with SIP… how can I use this expansion module? if I install SCCP firmware on the phone will that work?

I also tried to install SCCP on FreePBX and I get:

Include directory ‘/usr/include/asterisk’ does not exist
make: *** [.config] Error 1

I checked the modules folder in Asterisk and I see that is alread there… so does this means that SCCP is currently installed?

where are the asterisk headers? do I need to install additional package?


check it out here -
Let everyone know how you get on.

I did follow that link

I don’t know where the Asterisk headers are, make I run “make” I get this:

Include directory ‘/usr/include/asterisk’ does not exist
make: *** [.config] Error 1


I’m in the same boat. I’d like to integrate SCCP into FreePBX, but I don’t have the headers required when attemping to configure the chan_sccp2 driver.
Anyone have any further experience here?

You will have to rebuild asterisk from source and resolve any necessary sccp necessities (maybe skinny is all you need)


(hopefully these external references are not considered too transient to be allowed :wink: )