Installing freepbx module from CLI


Asterisk 13.10.0

SHMZ release 6.6 (Final)

i have a script that help me install new module to all of our severs.
the script :

  1. transferring new module file to - /var/www/html/admin/modules/
  2. setting file premissions - chown asterisk. && chmod 775
  3. amportal a ma install $MODULENAME
    (at this point i can see the new module at module admin in freepbx but as not installed)
  4. /var/lib/asterisk/bin/module_admin install $MODULENAME
    (this making the installing throw CLI )

my issue is- if i have a big server with a lot of recording for some reason the command start to set permission to all recordings! its taking forever.

can i skip it somehow ?
this is the output:

!!!!amportal is depreciated. Please use fwconsole!!!!
forwarding all commands to 'fwconsole'
Taking too long? Customize the chown command, See
Setting Permissions...
	Collecting Files...Done
 39738/39738 [============================] 100%
Finished setting permissions

The answer to your question appears to be in your question. Did you not see this?

1 Like

but nothing there helped me as i dont have the file /etc/asterisk/freepbx_chown.conf

more ideas ?

If you read the article. It shows you how to create the file and what to put in it.

1 Like

you right- my mistakeā€¦
ill try and update.

Thank you.


Please add the file /etc/asterisk/freepbx_chown.conf to your pbx, and the following lines to skip the permissions settings of the recordings in the server. Furthermore, switch to fwconsole instead of amportal.

directory = /var/spool/asterisk/monitor/

Thank you,

Daniel Friedman
Trixton LTD.

1 Like