Installing FreePBX - Error 255i

Hi everyone I’m installing FreePbx; I run the command “” “” $ sudo ./install -n --dbuser root --dbpass “yourpassword” “” “” "and it gives me error 255 as you can see attached. I installed everything on a virtual machine of virtualbox; Asterisk was installed successfully.

Debian version is 11.00 so I guess you don’t have to install php 7.3 as php 7.4 is already included.

I read on the net that it is a problem due to the php 7.4 version; however I try to install and then downgrade to version 7.3 (with this command “” “” php php-pear php-cgi php-common php-curl php-mbstring php-gd php-mysql php-gettext php-bcmath php- zip php-xml php-imap php-json php-snmp php-fpm libapache2-mod-php “” “” "), but I get the error on the php-gettext package.

I also run the command $ sudo ./install -n to follow the menu step by step answering the questions but the result is always the same error 255 as per attached image.

Can someone help me?


Unless you are really ‘clever’ ( your posted ‘command’ was either mangled by the forum here or just not understandable ) try reverting to Debian 10 (or 9), If you are new at this, maybe use the “distro” for now.

The command is correct. I only know that the administrator who manages the forum here has changed the title from 255 to 255i but the command is that. If you have not installed Freepbx on Debian 11 you cannot answer. If, on the other hand, you have installed Freepbx on debian 11 and you don’t want to tell me how to do it, at this point I wonder what this forum is for. regards

I have, several times, and with no problem, Here is a recipe very similar to what I do

I personally wonder if you think your posted

(with this command “” “” php php-pear php-cgi php-common php-curl php-mbstring php-gd php-mysql php-gettext php-bcmath php- zip php-xml php-imap php-json php-snmp php-fpm libapache2-mod-php “” “” ")

is a valid command to debian bullseye and not in actual fact a ‘typo’

Installing FreePBX using sudo is not generally recommended, the ‘environment’ is not exactly the same as being ‘root’ .

You can add --verbose n to the install script’s arguments.,

It is easier for us to read console output than decipher photos.

Hopefully you will find both the wiki and these fora to be didactic.

i ran the procedure you post to me and when i run ./install -n i get the error:

Unable to read /etc/asterisk/asterisk.conf or it was missing a directories section.

I ran step by step for each command in the guide I think the problem was here that moved the file with this command:

systemctl stop asterisk
systemctl disable asterisk
cd /etc/asterisk
mkdir DIST
mv * DIST
cp DIST/asterisk.conf .
sed -i 's/(!)//' asterisk.conf
touch modules.conf
touch cdr.conf

I tried to get the file back to its original location but it didn’t work. How can I recover?

Read a bash tutorial ?
Start over ?

I’m already starting over; however, if I repeat the procedure by creating the DIST folder and moving all the contents of “/ etc / asterisk” to the DIST folder with the mv command (as a guide) it will surely generate an error again because the ./install command will always refer to the folder “/ etc / asterisk” and not to the / etc / asterisk / DIST folder; for this I ask you the DIST folder should I create it? Is it necessary to move the contents of the / etc / asterisk folder to / etc / asterisk / DIST?

Why are you making things so hard for yourself? If you just want a PBX for your small business, download the Distro at Download | FreePBX - Let Freedom Ring , mount the .iso in VirtualBox and you’ll be up and running in less than an hour.

If you are doing a manual install because you’ll be integrating it with another ‘big’ package that requires Debian (CRM, predictive dialer, etc.), be aware that FreePBX expects to have the ‘whole machine’ and considerable expertise is required to make the packages coexist. It’s much easier to run the other big package in a separate VM on the same host, using the network to communicate between the systems.

this is where you bring the asterisk.conf back into the /etc/asterisk folder.

Another way of thinking about it is you are getting rid of everything the packaging installs except asterisk.conf and you are manually creating empty modules.conf and cdr.conf files.

But is Asterisk included in this FreePBX distro or just freepbx? I’m just following a procedure provided by the link; I only know that the procedure asks me to create a folder with mkdir move all the contents in this folder / etc / asterisk / DIST and after a few commands it asks me to install ./install; after which the system refers to / etc / asterisk when trying to install with ./install and not to / etc / asterisk / DIST and this in my view is an objective error in the procedure not in the fact that a person is a novice or expert .

Anyway, if I download Freepbx as a virtual machine from the link you gave me, is Asterisk also included in the virtual machine?

Ok now try and say you

Ok there is Asterisk

I retried the procedure; when I create the DIST folder under asterisk and immediately after I execute the command mv * DIST, it gives me as output mv: cannot move ‘DIST to a subdirectory of itself,’ DIST / DIST '. It gives me an error but the content in DIST has been moved anyway but I would not want this error which then generates the error when I run ./install because it refers to / etc / asterisk and not to / etc / asterisk / DIST

You are missing the point. You do not use anything in DIST. The installer does not care about DIST. The only thing you are using is the asterisk.conf file and it belongs in /etc/asterisk/. If you don’t like the error that mv produces you can change it to mv * DIST 2>/dev/null

1 Like

I repeated the procedure once more; this time I also put the point that I had omitted; the error always appears


cat /etc/asterisk/asterisk.conf

I was the one who put SELINUX = enabled; I put it when I saw the error.

root @ debian: ~ # cat /etc/asterisk/asterisk.conf
runuser = asterisk; The user to run as.
rungroup = asterisk; The group to run as.
SELINUX = enabled

It doesn’t look like you followed the procedure at all. That file is garbage. Sorry, I can’t help you.


The error message is correct. This section would have been created during a standard installation of Asterisk. It’s also missing an options section and “selinux” is not a valid option.

The sample, which comes with the source code and may or may not be what is used during default installation is at asterisk/asterisk.conf.sample at master · asterisk/asterisk · GitHub

This thread is absurd; 20 posts and no resolution. If you just want a fricken PBX, run the Distro and call it a day. If you want something else, please describe your project and maybe we can suggest a better approach.