Installed new cxpanel module (iSymphony V3) and lost access to FreePBX GUI

I noticed that the new iSymphony V3 Module for FreePBX was release and installed it on an up todate version of FreePBX Distro. After it installed, I now see a blank screen after logging into the FreePBX GUI.

I tried to restart FreePBX from the command line using amportal restart but see the following error:

PHP Fatal error: Cannot redeclare class phpmailerException in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 3416

This appears to be related to the new module. I have been unable to uninstall the module from the command line and now have a broken installation.

Any suggestions on how to fix this would be greatly appreciated.


I’ve managed to get my GUI back working. I renamed the /var/www/html/admin/modules/cxpanel directory and managed to restart amportal. I then uninstalled the cxpanel module from FreePBX. After a bit of poking around I found that the areminder module also uses the class.phpmailer.php. I uninstalled this module and also the old iSymphony V2.8 module. I then was able to successfully reinstall the cxpanel module and everything is now working. Hope this helps narrow down what happened.

Your solution worked. However, did you end up re-installing iSymphony, without duplicating this issue?

Thanks for the info - sent a message to Mike at i9 - I will update if I hear anything back.


rm -rf /var/www/html/admin/modules/areminder && amportal a r && amportal a ma update areminder && amportal a r

Make sure you pick the Module that is available OnLine when you are checking - it offered mine that where already installed locally!

This is probably due to the fact that we have just included our module in the freepbx repo and you also have our manually installed module which are fighting with each other. We were not in the repo until yesterday.

Try uninstalling all the iSymphony V3 instances and deleting the /var/spool/www/html/admin/modules/cxpanel directory. Make sure all iSymphony V3 instances are gone. Then install the module from the FreePBX repo only. NOTE this will clear out the isymphony module database tables.

This will give you the latest module with the User Management support and as long as you update from the repo from this point on you should be fine.


The issue was actually due to a conflict between the PHPMailer library that comes with the cxpanel module and another module that also wants to include the same library. This issue has fixed and the changes are in cxpanel 3.1.1.

NOTE that there is also another issue with cxpanel 3.1.1 and loading of AGI scripts. We have resolved this issue as well and have pushed up the changes. The FreePBX team is reviewing these changes now. Once they are approved the AGI issue will be resolved with cxpanel 3.1.2.

Version 3.1.2 is now live and pushed to the mirror servers.

Tony - Can you clarify please?

3.1.2 is available for purchase in the store for FreePBX and PBXtended?

Version 3 is available in the store for FreePBX. Not in PBXact yet.

Ok, Preston. It’s under the Xactview brand right?


To be clear this was the first time I had installed the V3 module. I have only ever installed modules directly from the FreePBX Module Admin page.


All working fine again. Thanks for your help.


Yes and not currently available.