Installation Process Not Showing IP Addresses

Hi, I just got to installing FreePBX on a pc I built. I allowed the program to reboot and now I’m in some kind of terminal. I was watching this video by crosstalksolutions and the gentleman mentioned seeing an IP Address after freepbx reboots.

The IP Address section is blank for me even though I have an ethernet cable running into the PC, I can only see the MAC Address. Did I do something wrong somewhere? I’m a layman trying to get a pbx system up for my boss’ business, no past experience in IT :frowning:

Please help the free pbx ducky lol


Not sure what installation process you did, but did you set it should pull from DHCP? Do you have a DHCP server on your network?

I did the standard one with asterisk 16 (recommended). I’m really new with this stuff so I’m sorry if I give any wrong info. I’m not exactly sure if it’s using DHCP, but I can’t get into settings of the router to check. Managed to get into the login for the router, though tried all variations of username and password for the model router, nothing worked. I’m at the shop and it’s 2:30am right now, ISP is Bell.

I reinstalled it and it’s revealing an IP!!! FINALLY!!! :slight_smile: I want pancakes too, I’m so hungry!!! I’ll be back to bother you guys if anything else comes up, which I’m almost 100% sure will happen.

Thank you!

1 Like

Yea, I have the same experience as well when logging in via console after reboot. But quickly I did a ifconfig that shows me the IP address.

Only a while later when I ssh into the box I see the banner and IP address show up.

So I ran into another issue, the IP address it originally gave me doesn’t work anymore, it kicked me out of the setup wizard around the part for trusting the network (would register undefined), IP stopped working. Today the server is giving me a strange IP address (fe80:ca–:etc…). No idea what’s to be done.

I added ip addr, but it doesn’t give me an real IP like the one before. Wish there was better troubleshooting for noobs.

Were you able to login locally? what does ifconfig gives you?

Sounds like you get an IPV6 address.

the fe80:… address is a REAL ipv6 address, look to your dhcp service

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.