Installation Problems

I have been using Elastix so far, but it has become a little bloated over time and so I am looking for a more lightweight installation like FreePBX.

My installation went well and I manually copied all FreePBX configuration entries from Elastix to FreePBX. However, I was hoping to try some of the “new” stuff and so I setup my extensions using PJSIP. My system is using two trunks. One is using MyDivert and I was able to convert that one to PJSIP as well.

However, I am struggling with the second trunk using BroadVoice. I mean it registered fine, but I am unable to make (or receive) calls through the trunk. Is anybody using BroadVoice here as well and got it to work? Meanwhile, I have been able to get it to work using the old SIP.

I was also hoping that an old problem using Elastix would go away, but sadly it didn’t. Basically, I can make calls through the trunk, but I am having one-way audio (SIP phones to Zoiper) or no audio (SIP phone to SIP phone). This has always been bugging me because my family would finally like to be able to make a call from extension to another at home… I am guessing that this is a NAT problem, but I believe our setup isn’t unusual. Here is what we got:

10.10.x.y subnet with FreePBX and internet gateway
192.168.x.y subnet with SIP devices, soft phones (ZOIPER) and separate internet gateway
Both subnets are fully connected and can see each other without any problems.

Interestingly enough soft phones work when I am not at home (different wireless network or cellular data network). So, it seems that NAT between 10.10.x.y and the outside world is working just fine.

I am guessing what isn’t working is the connection between the two subnets. I am suspicious that the system is attempting to NAT this connection which is not needed.

I would appreciate it if somebody could help me out getting my installation to work. Thank you in advance!

So, nobody is using BroadVoice with PJSIP?

Any pointers for resolving one-way audio between two subnets?

I got most one-way audio issues resolved by using a STUN server whenever possible.

Only issue are calls from my wife’s office SIP phone (Yealink) to my office SCCP phone (Cisco). It works fine if I call her, but it doesn’t work the other way. I will post an update if I can find a solution.

Migration is almost complete now! :smile:

Well, I guess I would still like to migrate BroadVoice to PJSIP one day…

Can I ask why the two subnets?

I am having enough problems getting Pjsip to work on one subnet at the moment.

What settings do broadvoice use?

Hi Paul,
I am sorry about the slow reply, but I have been ill in the past few days.

Quick update: I got the Yealink to work. I missed a setting under advanced named RPort. It needs to set to enabled to work for local calls.

I am having two subnets because FreePBX is located in a different location that is connected to my home office by VPN. So, subnet A is used for the location of FreePBX and subnet B is used for my home office.

Well, I got BroadVoice working with CHAN_SIP and I am using the following settings.

Outgoing -> Peer Details

Incoming -> Register String
user_name:[email protected]/<user_name>

I am guessing that CHAN_PJSIP isn’t working because of the register string.

Otherwise, I got all extensions working on CHAN_PJSIP.

Based upon the very limited information you’ve provided, I’m going to guess that the problem is in your routing between subnets. Not all routers do a good job, and many screw up routing of SIP. Same with VPNs. Have you tried a different router? Have you tried a different VPN? I use OpenVPN with Vyatta and it works great. I migrated from an expensive Cisco solution that was terrible.

Also, I continue to believe that PJSIP is not ready for primetime, and that you should stick with Chan_sip for now.

I would have to agree with your comments on PJSIP. I have really struggled to get trunks working on PJSIP that easily work on Chan_Sip.

The extensions seem OK but general reliability appears very poor, the channel has stop quite a few time for me with all the extensions becoming unavailable. I think the problem is PJSIP does not support dynamic ip addresses which sadly many of us have to use.

It really feels like a massive step backwards, I hope chan_sip is supported for quite a while yet, I don’t think I could rely on a PBX that only had PJSIP.

After doing some more research it seems clear that the issue I am having is caused by the register string.

In specific, it appears that CHAN_PJSIP makes assumptions around the register string that aren’t followed by all providers. Basically, a register string like user_name:[email protected] works, but Broadvoice is using [email protected]/phone_number which is not working.

Maybe CHAN_PJSIP should allow for a custom register string?