Installation Problems - UEFI

Trying to install FreePBX on an Acer Aspire R11 Notebook and not having much success. Trying to install via USB and CD.

I can’t get the .img files to work at all using Win32DiskImager. That just seems to create a USB stick I can’t read in Windows and doesn’t boot in UEFI or Legacy mode.

Had some success with unetbootin and iso2usb, by changing from UEFI to Legacy, however I’m getting a kickstart error that it can’t find the asterisk****.cfg file.

Finally, I bought a USB CD Rom and burnt the iso to DVD. Again I have to change from UEFI to Legacy to get it to boot, and this time it gets to the point where it goes to find the hard drive to install, and it says it can’t find any usable disks. I’m wondering if this could be because it’s formatted with GPT instead of MBR? Any recommendations of what try next?

So, in the tradition of two steps forward and one step backwards…

I thought I would try and convert the notebook’s SSD from GPT to MBR, so that everything would work as Legacy. My idea was to boot into a Win 7 install, Shift-F10 to a CLI and use diskpart to convert the SSD from GPT to MBR. I downloaded a Win7 ISO and burnt that to a GPT formatted USB using Rufus. Changed the notebook back to UEFI, and the good news was that the USB booted the Win 7 install. The bad news is that it crashed and froze at Starting Windows.

Can anybody suggest an alternate way to do this? This is driving me crazy. I (think) I need to convert the internal SSD to MBR so that I can run everything legacy and get out of UEFI hell.

Use the USB dvd drive to boot windows and you need official media for windows to ensure the windows installer will boot correctly. If you can make it work from USB (which it can) that’s fine, but to rule out the issues with boot, I would eliminate the added steps of creating and booting from a USB stick for now.

Thanks for the reply. Yes I tried that - I do have a Win 7 official DVD. The problem is, to get the Win 7 DVD to boot, I have to change to Legacy boot. Once it is booted this way, I go to a command prompt with Shift F10, and type in diskpart, but it reports there are no disks in the system. I suspect this is because the drive is formatted with GPT for UEFI, and I think this is what is happening with the FreePBX DVD install as well (ie it can’t see the drive because the system has booted in legacy). My thinking was to boot into UEFI mode with a USB stick, and hopefully that would let me see the disk so that I could then use diskpart to convert it to MBR, and then everything would be legacy. Trouble is, I can get my Win 7 UEFI install stick (created with Rufus) to boot, but it hangs while booting. Is there a way to create a UEFI install DVD for Win7?

I think what I’m looking for is other ways to create UEFI bootable media (CD or USB) that has a partitioning tool on it that would allow me to covert the SSD from GPT to MBR. Once the SSD is MBR, my theory is that I can set the BIOS to legacy, and the FreePBX CD install will be able to see the SSD drive and proceed with the install.I’m just not very proficient with building boot media (although I’m learning fast!)

Any suggestions greatly appreciated.

Most systems can boot to cd even uefi mode. I’m not sure why you are saying you cannot.

Yes I think this is the problem with this Acer machine. I cannot boot any non-UEFI devices if the BIOS is set for UEFI. I enabled the BIOS boot selection menu, and when I’m in UEFI mode, the SSD is listed, but the DVD drive or any other USB stick that is MBR does not appear. As soon as I put the UEFI formatted USB stick in, I can see it appear in the boot selection menu. If I switch to legacy mode, all the legacy boot devices will appear and I can boot from them, but I cannot boot from the SSD.

It seems this Acer strictly only boots UEFI devices in UEFI mode, and legacy devices in legacy mode, which I agree seems very unusual.

And yes I’ve got secure boot disabled.

What do you mean legacy devices vs UEFI devices? Any device added to a UEFI boot menu can be a UEFI device. UEFI does not classify boot devices as legacy or not. Typically you have to add boot devices to a UEFI menu either through BIOS which can insert the alternate boot device into the UEFI boot order or through the UEFI interface directly. I suspect it is the former on pc class machine.

OK, I think I’m confusing you with the BIOS boot priority order and the F12 boot manager menu that pops up when you enable it and press F12 after switching on. In BIOS under the Boot priority menu, I see all the devices - USB HDD, USB CDROM, USB FDD, the SSD disk (it is listed as EMMC: HB4Ge 32G) and Network boot devices. It is true that I see them all there in BIOS whether I am in UEFI or Legacy mode and can order and list them appropriately. The main difference is that when I switch from UEFI to legacy, Windows Boot Manager device disappears. However, when I enable the F12 boot menu on the device, if I am in UEFI mode, I only see the SSD and any UEFI imaged devices. When I switch the legacy mode, again I see all the devices in the BIOS boot priority list, and when I boot and press F12, I see any legacy imaged devices appear in the boot selection list. I also see the SSD, but it will not boot from it in legacy mode.

Eg. of the BIOS Boot Menu screen when set to UEFI:

Boot Mode: UEFI
Secure Boot: Disabled

Boot priority order:

  1. USB HDD:
  3. Windows Boot Manager
  4. EMMC: HB4Ge 32G
  5. USB FDD:
  6. Network Boot-IPV4:
  7. Network Boot-IPV6

So when I am in UEFI mode, and I have an official Win 7 install CD in the USB CD, it simply will not boot off the CD.

Whenever I switch from UEFI to Legacy it greys out the boot priority list and pops up a message saying the boot devices will not be updated until reboot.

And this is what it looks like in legacy mode:

Boot Mode: Legacy

Boot priority order:

  1. USB HDD:
  3. EMMC: HB4Ge 32G
  4. USB FDD:
  5. Network Boot: Realtek PXE B01 D00

It will boot from the CDROM in this mode, but it will not boot from the SSD. Note that it has actually detected and listed the device connected as the USB CDROM (GP60NB50 is the model number of the drive). This is one of the key ways I know the device is going to boot in particular mode - you see a description.

Hope that explains. This machine seems to only boot legacy (MBR) devices in legacy mode and UEFI (GPT) device in UEFI mode. Hence my desire to change the SSD from GPT to MBR.

So, the USB DVD device is available in UEFI mode according to that. If your system won’t boot the windows 7 disc that means it has not been modified and burned to boot properly on EFI. Windows 7 media almost always only boots in legacy mode though the files to boot in UEFI mode are already on the disc. Check this thread, make a custom EFI bootable windows 7 dvd and you should be on your way. Also, make sure your ‘BIOS’ is up to date also.

To "nuke " the efi of a disk then nuke the first and commonly the last bits of the disk (/dev/sda in this example)

The first bit is the partition table so

dd bs=512 if=/dev/zero of=/dev/sda count=2048 (count=1 should suffice)

should be more than enough

if necessary the efi partition also (probably not)

dd bs=512 if=/dev/zero of=/dev/sda count=2048 seek=$((blockdev --getsz /dev/sda - 2048))

but without a partition table than gpart, gparted or gdisk would probably get you back to an MSDOS schema if the disk is less than 4TB., many BIOS’s are broken with EFI booting, if you don’t need it, don’t use it.

Remember that with this GPT format, there is a partition table written to the end of the drive, where it will remain if you just try to delete it with fdisk or a non-GPT aware file system tool or the dd util as Dicko suggests. GPT disk needs to be converted with GPT award tools such as gdisk on Linux or diskpart in windows which is what th OP is trying to do.

dd is not aware of GPT,MBR or anything, just the disk gemetry. overwrite the offending data, and it is gone. That’s all. If you have the patience then

dd if=/dev/zero of=/dev/sda bs=1M

or slower but with feedback

shred -vfz -n 1 /dev/sda

chose your tool, tweezers or sledgehammer.

OK. so I got around to building the UEFI bootable Win 7 install DVD, as per mulderlr’s post. What a mission. I couldn’t use the DVD I had - it didn’t have \efi\microsoft\boot\efisys.bin file on it and the oscdimg of that failed. So I busted out the ISO I downloaded (officially) from Microsoft and used oscdimg on that - success. I now I have a bootable UEFI Win 7 install DVD, and the machine will boot in UEFI mode from it. Bad news: it does exactly same thing is the bootable UEFI USB stick I made and hangs at the Windows starting splash screen. So something is wrong with the ISO I got from MS. Going to try another ISO now.


So dicko, how do I create a UEFI bootable Linux DVD or USB with dd or gdisk on it? Sorry Linux really isn’t my forte. I just need to be able to get into this machine and kill GPT on the SSD (or at least that’s what I think is the correct course of action here).

Thanks for all the help guys. Really appreciate it.

I would start at

i’my sure one will work for you.

Unfortunately, after downloading a couple and reading the instructions and trying them, none of them seem to have the ability to burn a UEFI boot device. All of them created disks / sticks that would only boot in legacy mode on this confounded Acer machine.

So to recap, the only real success I’ve had with booting from CD / USB in UEFI mode is:

  1. Use Rufus to create a Win 7 UEFI bootable USB stick (set partition to GPT) from the downloaded Win 7 ISO
  2. Use the oscdimg process mulderlr linked to to create a Win 7 UEFI bootable DVD from the downloaded Win 7 ISO

BTW, seems only the 64 bit Win 7 ISO has EFI boot options / files. All the EFI files are missing from the 32 bit ISO.

However, both boot devices fail to start properly on this Acer machine (hang at the Win 7 splash screen).

Both the stick and DVD are fine - tried booting both on a Lenovo Edge 520 laptop and they boot into a Win 7 install without problem, so there was nothing wrong with the image I downloaded from MS.

Time for a whinge at Acer I think. Love the Lenovo BIOS which includes the option to boot both legacy and UEFI. Acer is utter crap.

Well you can blame Micro$oft probably.


particularly note:-

With the release of Windows 8 in October 2012, Microsoft’s certification requirements now require that computers include firmware that implements the UEFI specification. Furthermore, if the computer supports the “Connected Standby” feature of Windows 8 (which allows devices to have power management comparable to smartphones, with an almost instantaneous return from standby mode), then the firmware is not permitted to contain a Compatibility Support Module (CSM). As such, systems that support Connected Standby are incapable of booting Legacy BIOS operating systems.[66][67]

As you will see that depending on the “firmware” implemented by the manufacturer,then it is designed to allow booting from CDROM/USB OR “legacy” HDD’s. If your machine has a broken implementation and only supports the MS hegemony and has no or incomplete CSM code then maybe you’re screwed, so yes call them on that maybe they have a fix. . .

BUT, most of those disks I linked to DO include compliant GPT/EFI boot loaders. If not, any of the many current “live” linux distro’s (debian,BSD or RH based) will prove that point as they all also do UEFI booting on most anything.

1 Like

Thanks Dicko. Makes sense what you’re saying. Amazing how one vendor on a multi OS platform like the PC can dictate the hardware platform like that.

Could you point me to one that has instructions for burning a GPT/EFI image? I couldn’t find it.

all of which I suggested do, I don’t know if the “distro” you used is. but you could bootstrap yourself with an appropriate Centos or Debian iso and follow the appropriate wiki manual install recipe if it is not.

Hmmmm that went a bit over my head. I’ve been using Rufus to try and load the iso’s onto a USB stick, as it seems to be the only USB imaging tool that allows you to select a UEFI partition scheme (ie it has either MBR for UEFI or GPT for UEFI). All the iso’s I got off the link you posted won’t burn as UEFI because Rufus inspects them and knows they don’t have UEFI support. The Win 7 64bit ISO does, but I can’t get it to boot properly (and yes the Acer is 64 bit).

So I’ve downloaded the Centos ISO (minimal) and Rufus can use it to create UEFI (GPT) boot stick, which is now successfully booting under UEFI mode. I can break out to a Grub command line but I have no idea what to do next. Sorry for the ELI5 request, but could you help me with how would I re-partition the SSD to legacy MBR from here? Thanks in advance.

Try gparted , or perhaps go buy a USB dvd-writer :slight_smile: