Install Trouble On Ubuntu 8.04 - Asterisk won't start after FreePBX install

Trying to install FreePBX 2.4 on Ubuntu 8.04. Installing Zaptel, Asterisk, and Apache2 using the Ubuntu packages. Everything goes fine. Installing other FreePBX despendincies from the Ubuntu packages and still everything is fine. Now I run ./install_amp. Several things go wrong.

  1. At the end of the install I get a bunch of errors saying the the MYSQL database can not be connected to by [email protected]/amp109. The problem is I did not use that user name or password. I entered different information during the install. Why is the install trying to use the defaults now.

  2. Asterisk wont start now. If I try and use start_asterisk I just get the following over and over again:

STARTING ASTERISK
Asterisk ended with exit status 1
Asterisk died with code 1.
Automatically restarting Asterisk.
mpg123: no process killed
Asterisk ended with exit status 1
Asterisk died with code 1.
Automatically restarting Asterisk.

Thanks for any help or ideas,

John Morey

I have the same problem.
Asterisk starts normally when I reinstall asterisk-config, but with configs from freepbx it want start. If I start Asterisk with debug it just hangsup but no error is displayed. So I dont know for what it is waiting.

Any suggestion here?
Thanks a lot

You don’t say what version asterisk, but I have asterisk 1.6 with Ubuntu 8.04 running just fine. By that I mean it starts and stops just fine. I have not done any calls yet.

I am trying to install FreePBX and am having problems. I have another thread going for that one.

I had the same problem… solved by adding:

noload = app_directory_odbc.so
noload = app_voicemail_odbc.so
noload = app_voicemail_imap.so

to /etc/asterisk/modules.conf

Another problem you’re likely to encounter with Ubuntu Gusty Gibbon’s asterisk package and FreePBX is a hang during the “amportal start” script. I solved this by changing “BACKGROUND=0” to “BACKGROUND=1” in /usr/sbin/safe_asterisk.

Hope this helps :slight_smile:

M.

Hi there,

This might help you with the Astrix problems, it’s a good source of Ubuntu info & solutions
http://www.fixya.com/support/t914746-ubuntu_install_problem

Good luck.

I have installed asterisk and all the dependence packages from repos but having problems ./install_amp for freepbx. getting this error “-bash: ./install_amp: /usr/bin/php: bad interpreter: No such file or directory”. my asterisk package is 1.4.17.

has anyone been able to solve this or install it successful? how did you solve it?

I highly recommend the wiki:

http://www.freepbx.org/trac/wiki/UbuntuServerIntrepid

It is said to work for 8.04 as well.

Even if you are against trying a fresh install I would still recommend reading the wiki page, especially the part about disabling a couple modules. I had the same problem as the original poster until I disabled these two modules.

Thanks Zone-MR for the workaround here - saved me!