install_amp to remote mysql

hi,

i’m trying to install freepbx 2.1.0 to a remote mysql server, and i’m not having any luck. i can connect to the remote server w/mysql at the command line

mysql -h sql.example.net -u asteriskuser -p

Enter password
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 2 to server version 5.0.21-log

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the buffer.

mysql>

i’ve edited the amportal.conf to read like so

AMPDBHOST=sql.example.net

AMPDBUSER the user to connect to the database named ‘asterisk’

AMPDBUSER=asteriskuser

AMPDBENGINE the type of database to use

AMPDBENGINE=mysql

AMPDBPASS the password for AMPDBUSER

AMPDBPASS=secretpassword

when i run install_amp i get this

./install_amp --debug

Checking for PEAR DB…OK
Checking for PEAR ConsoleGetopt…OK
[DEBUG] Debug mode enabled
Checking user…OK
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Checking for /etc/asterisk/asterisk.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Checking for Asterisk 1.2…OK
Checking for selinux…OK
Connecting to database…FAILED
[DEBUG] [nativecode=Access denied for user ‘[email protected]’@‘localhost’ (using password YES)] ** mysql//[email protected]@localhost/asterisk
Try running ./install_amp --username=user --password=pass (using your own user and pass)
[FATAL] Cannot connect to database

anyone know what i need to edit in the install_amp script to fix this?

thanks!

jimbothigpen

sorry for the noise…

found the answer in the mailing list archives

run install_amp with --dbhost= switch.

–jimbothigpen