./install_amp -- ***** Failing *****

When I run ./Install_amp after going through script. it gives me cannot connect to database.

I have gone through every step. I can login with the user and password in amportal.conf withouth any problem… I have tried --username and --password switches… with no luck. I have looked at the privileges they are there… user is asteriskuser and password i changed from the normal one to a different password.

I just need some guidance…

Thanks
WK

Does the password match mysql?

You should be able to login to mysql with the username and password like this:

[vg2.xxx.net ~]# mysql -u asteriskuser -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1035654
Server version: 5.0.77 Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| asterisk           |
| asteriskcdrdb      |
| asteriskrealtime   |
| endpoints          |
| test               |
+--------------------+
6 rows in set (0.02 sec)

mysql> exit
Bye
[vg2.xxx.net ~]#

Use the following to update password in MySQL:

mysql> GRANT ALL PRIVILEGES ON asteriskcdrdb.* TO [email protected] IDENTIFIED BY 'amp109';
Query OK, 0 rows affected (0.00 sec)

mysql> GRANT ALL PRIVILEGES ON asterisk.* TO [email protected] IDENTIFIED BY 'amp109';
Query OK, 0 rows affected (0.00 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

Substitute amp109 for your password.

Ok… did those same issues… asteriskuser i am able to login using

mysql -u asteriskuser -p

i can see the databases and the tables…

What version are you running of FreePBX. What OS?

If 2.9 look in /etc/freepbx.conf, make sure it matches and do an amportal restart.

Don’t edit /etc/amportal.conf in 2.9

Thank you Skyking…

The issue was password. I had special characters in password including @ … this was what creating issues. after I changed password and removed that character… everything else worked like a charm… thank you again.