Initial Setup - can't connect to mysql

I followed this install guide:
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+7

Everything installed fine, but I messed up this part up


As part of this install, you will be asked several times for a mysql password. You can leave this blank (just push enter) as the instructions further down will generate a secure password. If you set a password now, you will cause problems further down. Please do not set a mysql password unless you are confident in your abilities to secure a SQL server.

last part of install:

[[email protected] freepbx]# ./install
Database engine [mysql]:
Database name [asterisk]:
CDR Database name [asteriskcdrdb]:
Database username [root]:
Database password:
File owner user [asterisk]:
File owner group [asterisk]:
Filesystem location from which FreePBX files will be served [/var/www/html]:
Filesystem location from which Asterisk configuration files will be served [/etc/asterisk]:
Filesystem location for Asterisk modules [/usr/lib64/asterisk/modules]:
Filesystem location for Asterisk lib files [/var/lib/asterisk]:
Filesystem location for Asterisk agi files [/var/lib/asterisk/agi-bin]:
Location of the Asterisk spool directory [/var/spool/asterisk]:
Location of the Asterisk run directory [/var/run/asterisk]:
Location of the Asterisk log files [/var/log/asterisk]:
Location of the FreePBX command line scripts [/var/lib/asterisk/bin]:
Location of the FreePBX (root) command line scripts [/usr/sbin]:
Location of the Apache cgi-bin executables [/var/www/cgi-bin]:
Directory for FreePBX html5 playback files [/var/lib/asterisk/playback]:
Assuming you are Database Root
Checking if SELinux is enabled…Its not (good)!
Reading /etc/asterisk/asterisk.conf…Done
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…Done
Preliminary checks done. Starting FreePBX Installation
Checking if this is a new install…Yes (No /etc/freepbx.conf file detected)
Database Root installation checking credentials and permissions…Error!
Invalid Database Permissions. The error was: SQLSTATE[28000] [1045] Access denied for user ‘root’@‘localhost’ (using password: NO)

I’ve looked in my local mysql database, and have not seen any new DBs or users.

I’m a semi noob - so this is mostly new to me . . .

Invalid Database Permissions. The error was: SQLSTATE[28000] [1045] Access denied for user ‘root’@‘localhost’ (using password: NO)

Indicates that you DID set a root password.

Yes, that’s my problem.
I don’t know how to fix that. Unable to find the config or reverse what I did, stuck

Luckily we now have google ::slight_smile:

https://dev.mysql.com/doc/refman/5.7/en/resetting-permissions.html