Incredible fax 2

Hi all,
I installed “PBX in a flash” according to the nerd-vittles article:

Dahdi: 2.6.0
Libpri: 1.4.12
OS: CentOS 6.2
Incredible PBX: 3.0.4

Hylafax: 6.0.5
Iaxmodem: 1.2.0
Avantfax: 3.3.3
Tesseract: 3.0.1
Lepton: 1.68
Incredible FAX: 2.1.2

I dedicate a Google voice number,
for the incoming faxes,(misc destination > fax).
and for the and the outgoing faxes.

I have no problem to send a fax via the avantWEB, and the fax reach the destination.

But when someone send me a fax,
I can see in the avantFAX and in the asterisk CLI that i am receiving a fax, but i can’t see it in the avantWEB or in the mail i set.

the only errors (i don’t even sure this is an error) that i see in the asterisk CLI that Related to the FAX, is this massages:

[2012-02-14 09:17:59] NOTICE[1707] chan_iax2.c: Peer ‘iax-fax0’ is not dynamic (from
[2012-02-14 09:17:59] NOTICE[1707] chan_iax2.c: Peer ‘iax-fax1’ is not dynamic (from
[2012-02-14 09:17:59] NOTICE[1700] chan_iax2.c: Peer ‘iax-fax2’ is not dynamic (from
[2012-02-14 09:17:59] NOTICE[1700] chan_iax2.c: Peer ‘iax-fax3’ is not dynamic (from


this is my FAX Module configuration:

if the AvantFAX settings (in the Avant WEB) is crucial to determine the problem, i will add them on request.

thanks in advance,


You will likely find better success asking for help on the PBX in a Flash forums for your issue. Most likely, your problem has nothing to do with FreePBX, but rather the problem is with AvantFAX, Hylafax, or IAXModem.

I have personally tested the latest releases from PIAF, including the Incredible PBX 3 and Incredible Fax 2. Although some may have had success with it, there are problems with the Incredible Fax 2 installation. Unfortunately, the install routine for Incredible Fax 2 is proprietary and cannot be viewed and/or edited before running the install. I found numerous mistakes in the installation that proved to cause problems that were difficult to overcome.

On the other hand, I found much better success installing each of these components individually from source. This took much more work on my part, however the result was a solid setup that I know is correct. In the process, I also learned alot about each of the components, which has proved valuable in maintaining a reliable system.

Ultimately, since the development team for PBX in a Flash are responsible for writing the install and setup routines, they will be in a position to provide support for their work.



There were certainly a few growing pains with the release of Incredible Fax 2. That’s what beta means. We have lots of “pioneers” that test our new stuff. If you prefer not to be a pioner, then wait for the final release or post your feedback on the PIAF Forum.

Most, if not all, of the issues were the result of the move to CentOS 6.2. Keep in mind that Hylafax, AvantFAX, and IAXmodem are complex pieces of software that all have to work together. And we support both 32-bit and 64-bit versions of CentOS 6.2 and Asterisk which added another wrinkle in the complexity puzzle.

In less than 60 days, we think all of the kinks have now been worked out. So new installs should go quite smoothly. After a base PIAF2 install, decide whether you want to add Incredible PBX. If so, run install-incredpbx3. If not, skip that step. Now run install-incredfax2, and you’re all set. Each setup takes only a couple minutes. See our Nerd Vittles article for more detail:

If you have an existing install of Incredible Fax 2, we’d recommend starting over. If that isn’t possible, then see this thread for suggestions on getting Humpty put back together again: Depending upon when you installed the software, there was an early permissions issue on a few directories that caused incoming faxes to fail. That, too, has been addressed both in the latest release AND in the forum thread I’ve referenced. Enjoy!

thenks for the replays.
i manged to fix the problem.
i fix the Permissions in the /var/www/html/avantfax
and avreything worked.

thanks guys.