Incomming Calls going to context from-sip-external

Hi,
I have a Unify PBX and connected the FreePBX as a SIP Client.
I FreePBX I used Trunk to register the FreePXX to the Unify PBX as a SIP Extension.13

13:[email protected]/13

From The UnifyPBX I can now make calls to 13, but the incomming call on the FreePBX are going to extension from-sip-external intstead of extension from-trunk:

— SIP read from UDP:192.168.xxx.xxx:5060 —>
INVITE sip:[email protected]:5160 SIP/2.0
Accept: application/sdp
Via: SIP/2.0/UDP 192.168.xxx.xxx;branch=z9hG4bK6327a9562c55eee72;rport
Max-Forwards: 70
From: sip:[email protected];tag=7e36d41392
To: sip:[email protected]:5160
Call-ID: b754f7ef644b88b2
CSeq: 1162416569 INVITE
Allow: INVITE, ACK, OPTIONS, BYE, CANCEL, REGISTER, REFER, PRACK, UPDATE
Contact: sip:[email protected]
P-Asserted-Identity: sip:[email protected]
User-Agent: OpenScape Business M5T SIP Stack/4.2.20.35
X-Siemens-Call-Type: ST-insecure
Alert-Info: ;info=alert-external
Content-Type: application/sdp
Content-Length: 332

v=0
o=OsBiz 1 1164940262 IN IP4 192.168.xxx.xxx
s=OsBiz
c=IN IP4 192.168.xxx.xxx
t=0 0
m=audio 29250 RTP/AVP 8 0 18 98 99
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:18 G729/8000
a=rtpmap:98 telephone-event/8000
a=rtpmap:99 red/8000
a=silenceSupp:off - - - -
a=fmtp:98 0-15
a=fmtp:99 98
a=ptime:20
a=sendrecv
<------------->
— (16 headers 16 lines) —
Sending to 192.168.xxx.xxx:5060 (NAT)
Sending to 192.168.xxx.xxx:5060 (NAT)
Using INVITE request as basis request - b754f7ef644b88b2
No matching peer for ‘00171xxxxxxx’ from ‘192.168.xxx.xxx:5060’
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
Found RTP audio format 8
Found RTP audio format 0
Found RTP audio format 18
Found RTP audio format 98
Found RTP audio format 99
Found audio description format PCMA for ID 8
Found audio description format PCMU for ID 0
Found audio description format G729 for ID 18
Found audio description format telephone-event for ID 98
Found unknown media description format red for ID 99
Capabilities: us - (ulaw|alaw|gsm|g726|g722), peer - audio=(ulaw|alaw|g729)/video=(nothing)/text=(nothing), combined - (ulaw|alaw)
Non-codec capabilities (dtmf): us - 0x1 (telephone-event|), peer - 0x1 (telephone-event|), combined - 0x1 (telephone-event|)
> 0x1e32550 – Strict RTP learning after remote address set to: 192.168.xxx.xxx:29250
Peer audio RTP is at port 192.168.xxx.xxx:29250
Looking for 13 in from-sip-external (domain 192.168.111.154)
sip_route_dump: route/path hop: sip:[email protected]

<— Transmitting (NAT) to 192.168.xxx.xxx:5060 —>
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.xxx.xxx;branch=z9hG4bK6327a9562c55eee72;received=192.168.xxx.xxx;rport=5060
From: sip:[email protected];tag=7e36d41392
To: sip:[email protected]:5160
Call-ID: b754f7ef644b88b2
CSeq: 1162416569 INVITE
Server: FPBX-15.0.16.42(16.6.2)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Contact: sip:[email protected]:5160
Content-Length: 0

<------------>
– Executing [[email protected]:1] NoOp(“SIP/192.168.xxx.xxx-00000000”, “Received incoming SIP connection from unknown peer to 13”) in new stack
– Executing [[email protected]:2] Set(“SIP/192.168.xxx.xxx-00000000”, “DID=13”) in new stack
– Executing [[email protected]:3] Goto(“SIP/192.168.xxx.xxx-00000000”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/192.168.xxx.xxx-00000000”, “1?setlanguage:checkanon”) in new stack
– Goto (from-sip-external,s,2)
– Executing [[email protected]:2] Set(“SIP/192.168.xxx.xxx-00000000”, “CHANNEL(language)=de_DE”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/192.168.xxx.xxx-00000000”, “1?noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [[email protected]:5] Set(“SIP/192.168.xxx.xxx-00000000”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2020-04-21 17:04:53.313 UTC.
– Executing [[email protected]:6] Set(“SIP/192.168.xxx.xxx-00000000”, “receveip=recvip”) in new stack
– Executing [[email protected]:7] Log(“SIP/192.168.xxx.xxx-00000000”, “WARNING,“Rejecting unknown SIP connection from 192.168.xxx.xxx””) in new stack
[2020-04-21 17:04:38] WARNING[26500][C-00000001]: Ext. s:7 @ from-sip-external: “Rejecting unknown SIP connection from 192.168.xxx.xxx”
– Executing [[email protected]:8] Answer(“SIP/192.168.xxx.xxx-00000000”, “”) in new stack

Thanks dor help.

FreePBX is (correctly) set up to not allow anonymous connections, but your Unify isn’t set up correctly in the FreePBX trunk. You need to add the IP to the trunk config.

Thank you

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.