Incoming Trunk Settings DID Configuration

I have 2 DID numbers from my voip termination service that I am trying to route to [email protected] . I have all the settings correct for outgoing dialing which works correctly. I configured everything using FreePbx for outgoing. I thought that it would be simple to get the incoming lines going but I cant find anywhere online that states the configuration settings. Can anyone clue me in here?

I have placed the following code into extensions_custom.conf

;exten => 4805038553,1,Answer
;exten => 4805038554,1,Answer

when I do this asterisk actually answers the call yet it doesn’t ring at any extensions or play a ivr message.
I would like to know the simple settings to do this using Freepbx rather than editing the .conf files if possible.

Just create an Inbound Route for each of those DIDs. Make sure your Trunk has the context=from-pstn configured (you don’t specify what context you put those Answer commands into in extensions_custom.conf – if its in [from-internal-custom] then your context for the Trunks is wrong).

the following is what is in PEER DETAILS


allow=all
context=ext-did
host=iax.exgn.net
secret=*******
type=friend
username=****


here is what I need to know
what goes in:
USER Context: _______________
USER Details:_________________

Register String: klumix:********@iax.exgn.net

actually I got it ringing through with the following script in extension_custom.conf
[inbound]
exten => 4805038553,1,Answer
exten => 4805038553,2,Dial(SIP/1000,25,Ttr) ; incoming calls are redirected to SIP telephone with number 1000
exten => 4805038553,3,Hangup

but I want to be able to do everything through the FREEPBX Gui

[quote=“klumix”]actually I got it ringing through with the following script in extension_custom.conf
[inbound][/quote]

The fact that it works on the [inbound] context indicates that your Trunk configuration is incorrect. You should have:

[code:1]context=from-trunk[/code:1]

In the Trunk definition. Then the Inbound Routes in FreePBX will work. Until you make this change, the Inbound Routes will NOT work, as the incoming calls will not bee seen by FreePBX’s dialplan.

ok and where do I put that is that under peer details?

So are you saying it should be like this under peer details?
allow=all
context=from-trunk
host=iax.exgn.net
secret=*******
type=friend
username=*****

Yup, that’s right. :slight_smile: Then, the Incoming Routes will work.

ok well thats what I changed and it still doesnt work, any ideas?

use the inbound route in freepbx
put in the DID and tell where to go.
easy

Here is my inbound route settings for this DID

DID Number: 4805038554
Caller ID Number: 4805038554
Fax Extension: disabled
Privacy Manager: no
immediate answer: no
pause after answer: no
set destination: Core [selected] <1001>

Its still not working and it seems like it should, what is wrong here? Or if this is correct, how do I reset freepbx to original defaults becuase maybe I tweaked something that is screwing it up.

thanks

Read the tool tips:

DID Number: Define the expected DID Number if your trunk passes DID on
incoming calls.

Leave this blank to match calls with any or no DID info.:

Caller ID Number: Define the Caller ID Number to be matched on incoming calls.

Leave this field blank to match any or no CID info.:

On 6/8/06, Tom Vile [email protected] wrote:

[quote] Take out the Caller ID Number: 4805038554 and leave the DID number in.

Having
DID Number: 4805038554 and Caller ID Number: 4805038554 is telling the
system to route the call coming in on DID 4805038554 and Caller ID
4805038554 to somewhere but you dont do it that way.

On 6/8/06, klumix [email protected] wrote:

Here is my inbound route settings for this DID

DID Number: 4805038554
Caller ID Number: 4805038554
Fax Extension: disabled
Privacy Manager: no
immediate answer: no
pause after answer: no
set destination: Core [selected] <1001>

Its still not working and it seems like it should, what is wrong here? Or if this is correct, how do I reset freepbx to original defaults becuase maybe I tweaked something that is screwing it up.

thanks


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856

[/quote]


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

ok tried that it still doesnt work., I know this is supposed to be something simple, I must have changed something in my extensions.conf that is messing it up because when I do this manually it works fine. How do I get extensions.conf back to the way it was when I installed it?

How are we suppose to know how to get extensions.conf back to the way
it was before? You changed it. Come on you cant figure out how to
get a new extensions.conf file?

On 6/8/06, klumix [email protected] wrote:

[quote] ok tried that it still doesnt work., I know this is supposed to be something simple, I must have changed something in my extensions.conf that is messing it up because when I do this manually it works fine. How do I get extensions.conf back to the way it was when I installed it?


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

[/quote]


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

Take out the Caller ID Number: 4805038554 and leave the DID number in.

Having
DID Number: 4805038554 and Caller ID Number: 4805038554 is telling the
system to route the call coming in on DID 4805038554 and Caller ID
4805038554 to somewhere but you dont do it that way.

On 6/8/06, klumix [email protected] wrote:

[quote] Here is my inbound route settings for this DID

DID Number: 4805038554
Caller ID Number: 4805038554
Fax Extension: disabled
Privacy Manager: no
immediate answer: no
pause after answer: no
set destination: Core [selected] <1001>

Its still not working and it seems like it should, what is wrong here? Or if this is correct, how do I reset freepbx to original defaults becuase maybe I tweaked something that is screwing it up.

thanks


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

[/quote]


Tom Vile
Baldwin Technology Solutions, Inc
Consulting - Web Design - VoIP Telephony
www.baldwintechsolutions.com
Phone: 518-631-2855 x205
Fax: 518-631-2856


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

ok , THAT IS WHAT I SCREWED UP!
Thanks tommy13v and Djelibeybi
For future viewers of this post , inbound DID from a voip termination service provider using FreePBX make sure that

Under Peer Details box include:
context=from-trunk

define an inbound route with the
DID Number: XXXXXXXXXX (enter your phone number )
Caller ID Number: (leave blank)
set destination: (choose desired setting)

I think you need all 11 digits in the number (he should watch the cli andsee what is happening)

run the asterisk -rvvvvvvvvvvvvvv
make inbound call, see what the call does…dropped …answered …what…

the problem is can not get DID number. if let DID and CID fields empty, will be receive phone calls.
I have 12 lines (isdn line with TE110P card) which has different numbers, I want to do: for example: 888888881 for receiptionist, 888888882 for supporter 888888883 for fax… also I did check it at CLI, if dial number 888888881 sometime is ZAP/3-1, sometime maybe ZAP/6-1. that’s number and zap channel is dynamic. How can I implement this ?

Just fill in the blanks for DID not CID
Set Destination to the exten you wish to ring for the DID and it must be right the same as it shows in the cli

I have been using Trixbox for quite some time. I decided to give FreePBX a shot an I am having a seemingly simple problem, but I can not figure out what is going on.

I have an inbound trunk setup (Exactly as I do in my production Trixbox system) and I am directing an inboud route to my only extension. It fails every time… The debug below shows the inbound call attempting to dail 5128 resulting in ==Everyone is busy…

Debug
– Executing [[email protected]:10] Dial(“SIP/dire_fvw3g-09dd8248”, “SIP/5128|15|tr”) in new stack
– Couldn’t call 5128
== Everyone is busy/congested at this time (0:0/0/0)
– Executing [[email protected]:11] Set(“SIP/dire_fvw3g-09dd8248”, “DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:10] Set(“SIP/dire_fvw3g-09dd8248”, “SV_DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:11] GosubIf(“SIP/dire_fvw3g-09dd8248”, “0?docfu|1”) in new stack
– Executing [[email protected]:12] GosubIf(“SIP/dire_fvw3g-09dd8248”, “0?docfb|1”) in new stack
– Executing [[email protected]:13] Set(“SIP/dire_fvw3g-09dd8248”, “DIALSTATUS=CHANUNAVAIL”) in new stack
– Executing [[email protected]:14] NoOp(“SIP/dire_fvw3g-09dd8248”, “Voicemail is 5128”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/dire_fvw3g-09dd8248”, “0?s-CHANUNAVAIL|1”) in new stack
– Executing [[email protected]:16] NoOp(“SIP/dire_fvw3g-09dd8248”, “Sending to Voicemail box 5128”) in new stack
– Executing [[email protected]:17] Macro(“SIP/dire_fvw3g-09dd8248”, “vm|5128|CHANUNAVAIL”) in new stack
– Executing [[email protected]:1] Macro(“SIP/dire_fvw3g-09dd8248”, “user-callerid|SKIPTTL”) in new stack
– Executing [[email protected]:1] NoOp(“SIP/dire_fvw3g-09dd8248”, “user-callerid: 2396455991 2396455991”) in new stack
– Executing [[email protected]:2] Set(“SIP/dire_fvw3g-09dd8248”, “AMPUSER=2396455991”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/dire_fvw3g-09dd8248”, “0?report”) in new stack
– Executing [[email protected]:4] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?start”) in new stack
– Goto (macro-user-callerid,s,6)
– Executing [[email protected]:6] NoOp(“SIP/dire_fvw3g-09dd8248”, “REALCALLERIDNUM is 2396455991”) in new stack
– Executing [[email protected]:7] Set(“SIP/dire_fvw3g-09dd8248”, “AMPUSER=”) in new stack
– Executing [[email protected]:8] Set(“SIP/dire_fvw3g-09dd8248”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] NoOp(“SIP/dire_fvw3g-09dd8248”, “TTL: 64 ARG1: SKIPTTL”) in new stack
– Executing [[email protected]:14] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“SIP/dire_fvw3g-09dd8248”, “Using CallerID “2396455991” <2396455991>”) in new stack
– Executing [[email protected]:2] Set(“SIP/dire_fvw3g-09dd8248”, “VMGAIN=”"") in new stack
– Executing [[email protected]:3] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?vmx|1”) in new stack
– Goto (macro-vm,vmx,1)
– Executing [[email protected]:1] GotoIf(“SIP/dire_fvw3g-09dd8248”, “0?s-CHANUNAVAIL|1”) in new stack
– Executing [[email protected]:2] Set(“SIP/dire_fvw3g-09dd8248”, “MODE=unavail”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?notdirect”) in new stack
– Goto (macro-vm,vmx,5)
– Executing [[email protected]:5] NoOp(“SIP/dire_fvw3g-09dd8248”, "Checking if ext 5128 is enabled: ") in new stack
– Executing [[email protected]:6] GotoIf(“SIP/dire_fvw3g-09dd8248”, “1?s-CHANUNAVAIL|1”) in new stack
– Goto (macro-vm,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] Macro(“SIP/dire_fvw3g-09dd8248”, “get-vmcontext|5128”) in new stack
– Executing [[email protected]:1] Set(“SIP/dire_fvw3g-09dd8248”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/dire_fvw3g-09dd8248”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/dire_fvw3g-09dd8248”, “”) in new stack
– Executing [[email protected]:2] VoiceMail(“SIP/dire_fvw3g-09dd8248”, “[email protected]|u”) in new stack
== Spawn extension (macro-vm, s-CHANUNAVAIL, 2) exited non-zero on ‘SIP/dire_fvw3g-09dd8248’ in macro ‘vm’
== Spawn extension (macro-vm, s-CHANUNAVAIL, 2) exited non-zero on ‘SIP/dire_fvw3g-09dd8248’ in macro ‘exten-vm’
== Spawn extension (macro-vm, s-CHANUNAVAIL, 2) exited non-zero on 'SIP/dire_fvw3g-09dd8248’
trixbox1*CLI>

trixbox1*CLI>

TRUNK PEER DETAILS
allow=g729
call-limit=50
canreinvite=no
context=from-trunk
disallow=all
host=xxxx.com
insecure=very
secret=xxxxx
type=friend
username=xxxxxx

Reg string is good: xxx:[email protected]

INBOUND ROUTE
DID Number: XXXXXXXXXX
CID: Blank

Destination: Extension 5128

I can not figure out what I am missing - this is the exact setting I use in Trixbox… Can anyone advise me as to whats going on?

Thanks and Happy New Year!

Seth