Incoming Calls Rejected - 5060 is closed

All, I have just started with Free PBX. I have installed the latest stable version, and added a SIP trunk.
I have set an inbound call route to play a recording, just to test that it is actually working.
I have forwarded port 5060 from the router to the freepbx host port 5060.
However, incoming calls are not coming through, just a busy tone is heard, my provider says that port 5060 is still closed (sure its open in the firewall, tested it by forwarding to 22 and i am able to run ssh)
hxxs:// shows port 5060 is closed (22 it shows as open)

asterisk -x " sip show peers" returns “unmonitored” as the status of the SIP.

How do I get this to work?

We’re going to need logs for us to trouble shoot this.

If you’re good at the Linux networking part, you can run a ‘tcpdump -I eth0 port 5060’ to see what is getting sent to the phone server.

You mentioned that you’ve port forwarded 5060, but have you port forwarded UDP port 5060 and 10000-20000 to the PBX? TCP isn’t going to cut it, and you need to forward 10000-20000 to get audio to work.

Thanks for your reply,
Here is the output of the tcpdump command

Forwarding rules in place (for the pbx):

UDP 5060 > PBX:5060
UDP 10000-20000 > PBX:same as incoming

What logs do you want me to share? (I am new to FreePBX)

Did you restart asterisk after setting your PBX port to 5060 ?

Restarted the entire server

Place a call and monitor asterisk -rvvv and post the logs here.

Not getting any special output…putty_2018-02-06_15-02-21

The tcpdump output tells us that you do not have port 5060 open/configured on the box. You are getting no responses from the server.

Since Asterisk is running, this means there is a problem in your SIP Configuration. Check your SIP settings for your trunks, as well as the SIP Settings under the “Advanced” tab (far right on the GUI).

Also, double check the Firewall settings to make sure that your local network can access the system. It’s possible that your machine has blacklisted your incoming traffic from the ITSP, so check out the firewall setup as well.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.