Incoming Calls Random Busy Signal


(United States) #1

I’m starting a new post for this issue. I have added this to the bottom of my old post over here:

It’s been just about 2 weeks that I’ve been messing around with this setup and I’m just about to pull the plug on it and send my phones back. I cannot find consistent information or I get a “read this” type of response in all of the forums I’ve visited. Most of the things I’ve read have not worked. Maybe I’m not using the right words when searching?

For the most part, I’ve been able to make outgoing calls. Incoming calls however, have been hit and miss. I’ve made dozens of test calls from my cell phone to my pbx and in some cases, when I call my pbx, I get a busy signal. If I wait a few minuts and retry, it works. Retry a minute or two later, it goes back to not working. This is potentially lost business and that is not acceptable. At this point, I’m frustrated with this whole system and that I’ve spent good money on and its not working consistently. I have NOT made any changes to the core configuration shown in my other post. The only changes are to the call flow, recordings and other things like this. Nothing with the trunk settings.

I’m sure its a config issue somewhere but where?!?! What am I doing wrong? I’ve included screenshots on my post above that shows my current settings and I don’t know what to change that will be that magic switch to make it just work. No, I’m not getting rid of the pfSense router. I need this to be secure and work. If not, I’m going to dump it. I have another 2 weeks before I’m outside the return period for the phones so I would rather get this working. I would really appreciate some constructive help.

FreePBX is running on a dual Xeon system with 12gb of ram. Its a HP ProLiant DL360 G7. 2 sangoma phones S305 and S505. Flowroute is my SIP provider and setup using CHAN_pjSIP. They do not want anyone using CHAN_SIP. I have all codecs set to G.729 and ulaw

When the calls do make it through to the pbx, the audio is choppy and sounds terrible. All files are recorded as WAV 16bit Mono 44,100. I’ve tried other formats and it sounds the same.

I’m unsure of what to look at to see where the error is or even what the error looks like.


(Dickson) #3

Sorry hit the delete button by accident

Watch the live log

asterisk -cvvvvvvvr

make a test call, you’ll see the live log scroll assuming its successfully ringing.
Press enter a couple of times to make a space
Call again. did it go busy? press enter a few times and try again.

IF you can make it ring busy and the log scrolls, post that section of log for us to look at.

If it DOESN’T" scroll then the problem is something else before the PBX. Provider or a network isssue.


#4

run sngrep and coordinate what you see with what is happening


(United States) #5

I’ve walked away from this for a bit so I could start fresh. I went and rechecked some settings against my screenshots with the thoughts of a setting getting changed. I had enabled TLS with a default certificate. I turned that off and its working OK so far. Maybe that had something to do with my issue? I may have turned this on and didn’t realise it. There are so many settings in so many different places, maybe I fat fingered something?

So I have no clue what the frick is going on, lol. I ran the command you suggested and made 34 test calls back to back. I would hang up as soon as I hit my greeting and redial the call. All of the 34 incoming calls hit the PBX. Previously it was maybe 2 or 3 that would make it to the pbx before a busy signal was heard. After that, it would be 4-5 calls before I would hit the pbx again. This cycle would repeat (I’m sure you understand my frustration). When I was getting busy signal issues, it was not making the log scroll at all but I was able to make outgoing calls and it would scroll.


(United States) #6

I stand corrected. Just made 4 more test calls with 1 making it to the PBX.


#7

Does sngrep show it at least making it to your network interface?


(United States) #8

Here is the output of sngrep. I blocked out the phone numbers. Those are the ones that hit the PBX and made it to the greeting. The ones with busy signal don’t seem to show up. I’m not really sure how to see if the call from the trunk is making it to my router or if it is, if its being blocked. I’m hoping its just that its on their end and not mine.

It looks like that the pbx is registering with the trunk regularly? I’m not sure what ping@invalid means.


#9

That is the front end of sngrep, and a good front end it is!, (R’ingTFM is always a ‘good thing’ :slight_smile: , ‘man sngrep’ ) , so just scroll to whatever and press enter. . . .

(at any time of confusion, press ?)