Incoming Calls not working - Google Cloud / Voip.ms

Incoming calls do not pickup, instead go to a recording of “The number you have reached is not in service”. I have tried to get this to work for a few days and have run out of ideas.

I’m wondering if I need to add my voip.ms pop server to the google/FreePBX firewall or maybe its a configuration issue. Either way if anyone can have a look at my log file I’d really appreciate some other ideas.

Thanks!

https://pastebin.freepbx.org/view/c5455c96

You don’t have an inbound route defined for 289479xxxx.

I had the inbound route DID set to any, I have now changed it to 289479xxxx but get the same result.

Here are my inbound route settings:

and a new log.

https://pastebin.freepbx.org/view/895159bb

It still doesn’t seem to be recognizing the DID. If I understand correctly, the presence of voip.ms in the channel name means it is recognizing the endpoint.

[2022-06-03 11:02:12] VERBOSE[6595][C-00000003] pbx.c: Executing [[email protected]:2] NoOp("PJSIP/voip.ms-00000002", "Received an unknown call with DID set to 289479xxxx") in new stack


[2022-06-03 11:02:12] VERBOSE[6595][C-00000003] pbx.c: Executing [[email protected]:3] Log("PJSIP/voip.ms-00000002", "WARNING,Friendly Scanner from ") in new stack

It’s saying there is no From header, and presumably no caller ID, but you are requiring it to match 289475… I think you should have left caller ID blank. Unfortunately, the security issue with the wiki means I can’t double check that caller ID is a match, rather than a set, parameter.

david55,

Thank you! Got rid of the caller id field and now it works! I really appreciate your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.