Incoming calls failed agfeo trunk

Hi I have problem with incoming calls to my PBX. Outgoing calls are without problem.
I tried to find solution but without success.
When I receive calls it finishes with :
[2022-12-12 22:05:28] ERROR[5797]: res_pjsip_session.c:938 handle_incoming_sdp: Elektro-pool: Couldn’t negotiate stream 0:audio-0:audio:sendrecv (nothing)
<— Transmitting SIP response (706 bytes) to UDP: —>
SIP/2.0 488 Not Acceptable Here

Here should be complete log of incomming call. Untitled - FreePBX Pastebin

Thanks for any help

It appears to be trying to negotiate secure RTP without any secure way of exchanging keys, that Asterisk could handle. Asterisk requires TLS, rather than UDP, and that the keys be included in the SDP. They are sending keys in the clear, which is pretty pointless.

It could also be that you haven’t included alaw in your allowed codecs.

alaw is allowed in codecs. Could you tell me what should I turn on or how to change the trunk? I tried to set transport to tls but then the trunk is offline and not connect. I’ve tried to enable Media encryption to SRTP via in-SDP but same story. Maybe I’m missing something important what should be set.

Both you and they must use TLS transport for SRTP to be acceptable.

They seem to be doing something very insecure. It is worse that not using SRTP, as people may believe the speech is secure, when it isn’t.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.