Incoming calls 'Fade Out' on static IP

Hi

We have a relatively stable FreePBX system. In the advanced SIP settings section we have

NAT = Yes
IP Configuration = Public

Calls work, both incoming and outgoing.

but

We are on a static IP address. So we should be able to switch IP configuration to ‘static’, and type in the

External IP = xxx.xxx.xxx.xxx
Local Networks = 192.168.0.0/255.255.255.0

However when we do this, outbound calls continue to work, but inbound calls do the following :

When we dial in we hear the first 20 secs of the IVR message and then the sound ‘fades out’ sharply and the call is dropped. During the IVR message that we can hear, none of the DTMF number options will work.

Anyone know what is going on?

Thanks

Is the static IP address on you router or on the FreePBX server?

This is the static IP of our router on the internet, so it’s the IP that computers external to our network will see

Do you have SIP port 5060 and RTP ports 10,000 - 20,000 forwarded from the firewall to the FreePBX box?

yes

5060 UDP
and 10,001-20,000

Try

Nat = No
IP Configuration = Public

This should work (even if you have NAT and don’t have a public IP) as long as you have no remote extensions and as long as you don’t forward any calls from an incoming SIP trunk to an outgoing SIP trunk without first picking up the call and playing some kind of audio.

If that doesn’t work, try another VOIP provider to see if there’s a difference. If your VOIP provider has a configuration option to support NAT, turn it on.

If that doesn’t work, try forwarding UDP ports 5060 and 10,000 through 20,000 to your PBX and see if that has any impact.

Hi

Thanks, but the configuration

Nat=Yes
IP Configuration = Public

Works fine at the moment. Ports are already forwarded.

My question is why (when I have a static IP) does switching IP configuration to ‘static ip’ have such a terrible effect

We don’t have any remote extensions and are not doing the SIP call forwarding thing you describe.

KR

It shouldn’t have that effect. I’ve used a static IP on all my FreePBX installs without encountering the problem you describe.

That’s why I’ve suggested trying another VOIP provider. If it only happens on the VOIP provider that you’re using now, then you should contact them for technical support.

The incoming call provider are SIPGate who are usually very good. We’ll look into trying someone else and report back.

Thanks